Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515750 - Invalid ResumeBehavior for HA VMs with nfs lease: Pause->UP instead of Pause->Kill->Up
Summary: Invalid ResumeBehavior for HA VMs with nfs lease: Pause->UP instead of Pause-...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ---
: ---
Assignee: Michal Skrivanek
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 10:02 UTC by Polina
Modified: 2018-01-24 07:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-23 09:14:02 UTC
oVirt Team: Virt


Attachments (Terms of Use)
see from line 14587 (EVENT_ID: VM_PAUSED_EIO(145), VM scsi_vm has been paused due to storage I/O problem.) till line 14588 ((scsi_vm) moved from 'Paused' --> 'Up') (deleted)
2017-11-21 10:02 UTC, Polina
no flags Details

Description Polina 2017-11-21 10:02:53 UTC
Created attachment 1356594 [details]
see from line 14587 (EVENT_ID: VM_PAUSED_EIO(145), VM scsi_vm has been paused due to storage I/O problem.) till line 14588 ((scsi_vm) moved from 'Paused' --> 'Up')

Description of problem:
The only option for Resume Behaviour of HA VM with lease is KILL. For VM with nfs lease it goes to UP with not kill.

Version-Release number of selected component (if applicable):
ovirt-engine-setup-plugin-ovirt-engine-4.2.0-0.0.master.20171119135709.git6d448d3.el7.centos.noarch

How reproducible: 100%

Steps to Reproduce:
1.create VM with iscsi disc, install RHEL OS. Check High Available with nfs lease, Resume Behaviour=KILL. Run VM.
2.Block iscsi storage on host (iptables -I INPUT -s 10.35.146.129 -j DROP). VM Paused.
3. Unblock the storage (iptables -D INPUT 1)
4. VM goes to Up state without kill.

Actual results:After the storage is back the VM goes from Pause to UP.

Expected results:
must be Pause->Kill->Up

Additional info:
The engine log attached

Comment 1 Tomas Jelinek 2017-11-21 15:57:18 UTC
Please provide also the vdsm logs from relevant timeframe and the name of the VM which on which it happens.

Comment 2 Michal Skrivanek 2017-11-22 05:37:43 UTC
Note that if the problematic condition lasts less than 80s by default it's not considered a problem and normal flow resumes. This is configurable, the default matches sanlock behavior

Comment 3 Tomas Jelinek 2017-11-23 09:14:02 UTC
Anyway, since the problematic conditions did not take longer than 80s, closing as not a bug because this is exactly what should have happened.


Note You need to log in before you can comment on or make changes to this bug.