Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515732 - all redhat-release-$VARIANT subpkgs are present in Server variant of RHEL-ALT-7.5
Summary: all redhat-release-$VARIANT subpkgs are present in Server variant of RHEL-ALT...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: redhat-release
Version: 7.5-Alt
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jon Disnard
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 09:43 UTC by Jan Blazek
Modified: 2018-12-07 22:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-07 22:35:47 UTC


Attachments (Terms of Use)

Description Jan Blazek 2017-11-21 09:43:54 UTC
Description of problem:

There are all variant-specific subpackages of redhat-release present in Server variant of RHEL-ALT-7.5 nightly composes:
redhat-release-client
redhat-release-computenode
redhat-release-server
redhat-release-workstation

I think this is a mistake.

$ grep redhat-release /mnt/redhat/nightly/RHEL-ALT-7.5-20171116.n.0/compose/metadata/rpms.json | grep rpm
                            "path": "Server/aarch64/os/Packages/redhat-release-7.5-0.12.el7a.aarch64.rpm",
                            "path": "Server/source/tree/Packages/redhat-release-7.5-0.12.el7a.src.rpm",
                            "path": "Server/aarch64/os/Packages/redhat-release-client-7.5-0.12.el7a.aarch64.rpm",
                            "path": "Server/aarch64/os/Packages/redhat-release-computenode-7.5-0.12.el7a.aarch64.rpm",
                            "path": "Server/aarch64/debug/tree/Packages/redhat-release-debuginfo-7.5-0.12.el7a.aarch64.rpm",
                            "path": "Server/aarch64/os/Packages/redhat-release-server-7.5-0.12.el7a.aarch64.rpm",
                            "path": "Server/aarch64/os/Packages/redhat-release-workstation-7.5-0.12.el7a.aarch64.rpm",
                            "path": "Server/ppc64le/os/Packages/redhat-release-7.5-0.12.el7a.ppc64le.rpm",
                            "path": "Server/source/tree/Packages/redhat-release-7.5-0.12.el7a.src.rpm",
                            "path": "Server/ppc64le/os/Packages/redhat-release-client-7.5-0.12.el7a.ppc64le.rpm",
                            "path": "Server/ppc64le/os/Packages/redhat-release-computenode-7.5-0.12.el7a.ppc64le.rpm",
                            "path": "Server/ppc64le/debug/tree/Packages/redhat-release-debuginfo-7.5-0.12.el7a.ppc64le.rpm",
                            "path": "Server/ppc64le/os/Packages/redhat-release-server-7.5-0.12.el7a.ppc64le.rpm",
                            "path": "Server/ppc64le/os/Packages/redhat-release-workstation-7.5-0.12.el7a.ppc64le.rpm",
                            "path": "Server/s390x/os/Packages/redhat-release-7.5-0.12.el7a.s390x.rpm",
                            "path": "Server/source/tree/Packages/redhat-release-7.5-0.12.el7a.src.rpm",
                            "path": "Server/s390x/os/Packages/redhat-release-client-7.5-0.12.el7a.s390x.rpm",
                            "path": "Server/s390x/os/Packages/redhat-release-computenode-7.5-0.12.el7a.s390x.rpm",
                            "path": "Server/s390x/debug/tree/Packages/redhat-release-debuginfo-7.5-0.12.el7a.s390x.rpm",
                            "path": "Server/s390x/os/Packages/redhat-release-server-7.5-0.12.el7a.s390x.rpm",
                            "path": "Server/s390x/os/Packages/redhat-release-workstation-7.5-0.12.el7a.s390x.rpm",
                            "path": "Server/source/tree/Packages/redhat-release-7.5-0.12.el7a.src.rpm",
                            "path": "Server/x86_64/os/Packages/redhat-release-7.5-0.12.el7a.x86_64.rpm",
                            "path": "Server/x86_64/os/Packages/redhat-release-client-7.5-0.12.el7a.x86_64.rpm",
                            "path": "Server/x86_64/os/Packages/redhat-release-computenode-7.5-0.12.el7a.x86_64.rpm",
                            "path": "Server/x86_64/debug/tree/Packages/redhat-release-debuginfo-7.5-0.12.el7a.x86_64.rpm",
                            "path": "Server/x86_64/os/Packages/redhat-release-server-7.5-0.12.el7a.x86_64.rpm",
                            "path": "Server/x86_64/os/Packages/redhat-release-workstation-7.5-0.12.el7a.x86_64.rpm",


Version-Release number of selected component (if applicable):

redhat-release-7.5-0.12.el7a
RHEL-ALT-7.5-20171116.n.0

Comment 2 Lubos Kocman 2018-05-28 11:37:18 UTC
Hello,

this was an issue caused by merge of srpm. This change was rolled back around beta timeframe.

RTT can you please confirm it's no longer issue and it was fixed in 7.5 GA?


Note You need to log in before you can comment on or make changes to this bug.