Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515728 - can't use dynamics items
Summary: can't use dynamics items
Keywords:
Status: CLOSED DUPLICATE of bug 1513159
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: GA
: cfme-future
Assignee: Dan Clarizio
QA Contact: Dave Johnson
URL:
Whiteboard: testathon
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 09:38 UTC by Cyril Coupel
Modified: 2017-11-24 11:58 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-21 13:18:57 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Cyril Coupel 2017-11-21 09:38:12 UTC
Description of problem:
with dynamics dialog items, entry points (/integration/forms/list_svc) are translated into (//integration/forms/list_svc/Process/AUTOMATION): 

Version-Release number of selected component (if applicable):


How reproducible:
every times with every item set to dynamics

Steps to Reproduce:
1. create a dialog with a dynamic drop down item 
2. set the entry point to /integration/forms/list_svc
3. create a catalog item to use this dialog
4. open the ordering page of this catalog item

Actual results:
the drop down show "script error"
the automation wants to use /integration/forms/list_svc/Process/AUTOMATION instead of /integration/forms/list_svc
the log says:
[----] I, [2017-11-20T10:30:30.893375 #25431:12b2414]  INFO -- : Instantiating [//integration/forms/list_svc/Process/AUTOMATION?MiqServer%3A%3Amiq_server=2&User%3A%3Auser=1&object_name=AUTOMATION]
[----] E, [2017-11-20T10:30:30.906299 #25431:12b2414] ERROR -- : Class [forms/list_svc/Process] not found in MiqAeDatastore

Expected results:
run the /integration/forms/list_svc instance and method

Additional info:

Comment 2 Greg McCullough 2017-11-21 12:47:35 UTC
Dan - Please review, I think this is a dup of bug 1513159.

Comment 3 Roman Blanco 2017-11-21 13:18:57 UTC

*** This bug has been marked as a duplicate of bug 1513159 ***


Note You need to log in before you can comment on or make changes to this bug.