Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515662 - describe design of tendrl-alerting, events and alerts shown in RHGS WA
Summary: describe design of tendrl-alerting, events and alerts shown in RHGS WA
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-RHGS_Web_Administration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: RHGS 3.3.1
Assignee: Rakesh
QA Contact: storage-qa-internal@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1502832 1502863
TreeView+ depends on / blocked
 
Reported: 2017-11-21 08:11 UTC by Martin Bukatovic
Modified: 2018-05-30 18:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-30 18:00:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1515318 None None None Never

Internal Links: 1515318

Description Martin Bukatovic 2017-11-21 08:11:32 UTC
Document URL
============

There is no url yet, this is related to documentation for RHGS WA.

Describe the issue
==================

We need to point out relation between Alerting as described in
upstream wikipage[1], Events page and Alerts in notifications
drawer in Tendrl UI[2].

We need to describe purpose of (including nature of items which
shown there):

* Events page in Tendrl UI
* Alerts notifications drawer in Tendrl UI
* Alerts forwarded by tendrl-alerting via snmp or smtp

[1] https://github.com/Tendrl/documentation/wiki/List-of-Alerts-and-Notifications-in-Tendrl
[2] https://github.com/Tendrl/ui/issues/663

Additional information
======================

Based on discussion under BZ 1515318, especially information provided
by Nishanth in https://bugzilla.redhat.com/show_bug.cgi?id=1515318#c2:

> Only Alert conditions are notified. Alert conditions are listed on
> the notifications drawer. If something which are listed there and not
> notified, then its a bug. This is as per design and not a bug.

Which I read as:

* items listed in Events page in Tendrl UI are not resent by tendrl-alerting
  via snmp/smtp
* all items in Alerts notifications drawer should be resent by tendrl-alerting

Comment 2 Martin Bukatovic 2017-11-21 08:16:30 UTC
bobbGT, feel free to reassign this BZ to a correct component

Comment 3 Martin Bukatovic 2017-11-21 08:17:16 UTC
Could you verify my conclusion there?

Comment 4 Nishanth Thomas 2017-11-21 11:16:45 UTC
(In reply to Martin Bukatovic from comment #3)
> Could you verify my conclusion there?

Yes, all the items in Alerts notifications drawer should be send out as notifications(email/snmp)

Comment 11 Rakesh 2017-12-12 13:54:57 UTC
Thanks Lubos, over to you for QA.

Comment 12 Lubos Trilety 2017-12-13 09:02:15 UTC
Looks fine


Note You need to log in before you can comment on or make changes to this bug.