Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515614 - Add pre-upgrade check to detect if there are bad content definitions
Summary: Add pre-upgrade check to detect if there are bad content definitions
Keywords:
Status: CLOSED DUPLICATE of bug 1520326
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Foreman Maintain
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: Unspecified
Assignee: Kavita
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1496794
TreeView+ depends on / blocked
 
Reported: 2017-11-21 06:03 UTC by Kavita
Modified: 2019-04-12 15:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-01 18:03:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 21713 None None None 2017-11-21 06:03:22 UTC

Description Kavita 2017-11-21 06:03:22 UTC
Description of problem:

candlepin migration step failed during installer run with following error:

liquibase --driver=org.postgresql.Driver --classpath=/usr/share/java/postgresql-jdbc.jar:/var/lib/tomcat/webapps/candlepin/WEB-INF/classes/ --changeLogFile=db/changelog/changelog-update.xml --url=jdbc:postgresql:candlepin --username=candlepin  --password=<PASSWORD> migrate -Dcommunity=False

If the content id is only being referenced by the default environment and no place else then it leads to above failure.

There should be check needed to detect if there are any bad content definitions.


Additional info:

Original bugzilla for reference - https://bugzilla.redhat.com/show_bug.cgi?id=1503176

Comment 1 pm-sat@redhat.com 2017-11-21 07:16:00 UTC
Upstream bug assigned to kgaikwad@redhat.com

Comment 4 Mike McCune 2018-02-01 18:03:52 UTC
this is taken care of with this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1520326

marking as a dupe

*** This bug has been marked as a duplicate of bug 1520326 ***


Note You need to log in before you can comment on or make changes to this bug.