Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515594 - Rhythmbox (build-in) Web Remote plugin is not working over Network.
Summary: Rhythmbox (build-in) Web Remote plugin is not working over Network.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 27
Hardware: Unspecified
OS: All
unspecified
unspecified
Target Milestone: ---
Assignee: David King
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 05:37 UTC by Steve
Modified: 2017-11-26 19:44 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-26 19:44:39 UTC


Attachments (Terms of Use)

Description Steve 2017-11-21 05:37:01 UTC
Description of problem:
Rhythmbox (build-in) Web Remote plugin is not working over Network.
After entering the access-key (on client), the button on the right side does work but nothing habppens. There is no error message, it just doesn't work. I don't know if it has something to do with javascript?

Version-Release number of selected component (if applicable):
rhythmbox-3.4.2-1.fc27.x86_64
firefox-57.0-2.fc27.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Activate the plugin in Rhythmbox (Server)
2. Go to the Website and enter the password in Firefox (Client/Linux)
3. Nothing happens

Actual results:


Expected results:
After entering the password, the client should be "logged-in".

Additional info:
It works locally (on Server).

Comment 1 Steve 2017-11-21 06:00:39 UTC
The same issue on M$ Windows with Firefox and Chrome.

Comment 2 gkrithi8 2017-11-26 11:34:00 UTC
Point to note:

It is a webremote ( not a web player yet, which it would be sometime ) plugin, which means it controls the music played in a remote machine, and not stream music from remote to local machine. 

So, when you click 'play' does it play in the server ?

Comment 3 Steve 2017-11-26 12:49:41 UTC
(In reply to gkrithi8 from comment #2)
> Point to note:
> 
> It is a webremote ( not a web player yet, which it would be sometime )
> plugin, which means it controls the music played in a remote machine, and
> not stream music from remote to local machine.

Of course, I know this.
 
> 
> So, when you click 'play' does it play in the server ?

No, nothing happens. This is the reason I filed the bug.

Comment 4 Steve 2017-11-26 13:44:06 UTC
I can't even log-in: Enter access key; Press '>'. Nothing happens.

Comment 5 gkrithi8 2017-11-26 16:29:31 UTC
Works fine here.

Attach output of "rhythmbox -D remote" here.

Comment 6 gkrithi8 2017-11-26 16:31:45 UTC
(In reply to gkrithi8 from comment #5)
> Works fine here.
> 
> Attach output of "rhythmbox -D remote" here.

After you have clicked '>'

Comment 7 Steve 2017-11-26 18:13:22 UTC
$ rhythmbox -D remote
(19:11:16) [0x55edfc85b230] [WebRemotePlugin.http_listen] /usr/lib64/rhythmbox/plugins/webremote/webremote.py:1025: relistening

(rhythmbox:4245): libsoup-CRITICAL **: soup_server_run_async: assertion 'priv->legacy_iface != NULL' failed

(rhythmbox:4245): Rhythmbox-WARNING **: Unable to grab media player keys: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SettingsDaemon was not provided by any .service files
(19:13:10) [0x55edfc85b230] [WebRemotePlugin.check_http_signature] /usr/lib64/rhythmbox/plugins/webremote/webremote.py:484: request timestamp: 1511719926411, min: 1511719930.092476, max: 1511720050.092476

Comment 8 gkrithi8 2017-11-26 19:25:23 UTC
Looks like the client and server machines have time difference ( > 60 secs ).

Are they synced ?

Comment 9 Steve 2017-11-26 19:44:39 UTC
Thank You very much for this useful information. After changing the time, it works. Closing...

$ rhythmbox -D remote
(20:39:18) [0x56074f266030] [WebRemotePlugin.http_listen] /usr/lib64/rhythmbox/plugins/webremote/webremote.py:1025: relistening

(rhythmbox:5070): libsoup-CRITICAL **: soup_server_run_async: assertion 'priv->legacy_iface != NULL' failed

(rhythmbox:5070): Rhythmbox-WARNING **: Unable to grab media player keys: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SettingsDaemon was not provided by any .service files
(20:42:01) [0x56074f266030] [WebRemotePlugin.check_http_signature] /usr/lib64/rhythmbox/plugins/webremote/webremote.py:484: request timestamp: 1511725331499, min: 1511725261.0509908, max: 1511725381.0509908
(20:42:01) [0x56074f266030] [WebRemotePlugin.check_http_signature] /usr/lib64/rhythmbox/plugins/webremote/webremote.py:490: request signature: 77163ea090ead69f, expecting: 77163ea090ead69f
(20:42:01) [0x56074f266030] [ClientSession.__init__] /usr/lib64/rhythmbox/plugins/webremote/webremote.py:127: new connection attached
(20:42:01) [0x56074f266030] [ClientSession.message_cb] /usr/lib64/rhythmbox/plugins/webremote/webremote.py:164: message received: {"action":"status"}
(20:42:01) [0x56074f266030] [ClientSession.message_cb] /usr/lib64/rhythmbox/plugins/webremote/webremote.py:168: doing status
(20:42:01) [0x56074f266030] [ClientSession.message_cb] /usr/lib64/rhythmbox/plugins/webremote/webremote.py:174: responding {'playing': False, 'id': 0, 'hostname': 'daleth'}
$


Note You need to log in before you can comment on or make changes to this bug.