Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515583 - Suspend fails the second time after every reboot. [NEEDINFO]
Summary: Suspend fails the second time after every reboot.
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1566152 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 05:07 UTC by Cregg Hardwick
Modified: 2018-08-29 15:24 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 15:24:03 UTC
jforbes: needinfo?


Attachments (Terms of Use)

Description Cregg Hardwick 2017-11-21 05:07:09 UTC
Description of problem: Suspend fails the second time after every reboot. Once failed, fan runs continuously, heating laptop and running down battery. Only holding the power button long enough to force shutdown or pulling the battery will get past the failed suspend.

To be clear, this is NOT a failure to restart after suspend. This is a failure to suspend. The screen goes dark and the machine hangs, but only the second time. The first suspend (whether from lid close of systemctl suspend,) always works.


Version-Release number of selected component (if applicable):
Happens in Fedora 26 and 27. Pretty sure it started after the last update to 25.


How reproducible
100% of the time, on the second attempt.


Steps to Reproduce:
1.Boot machine.
2.Suspend and resume through any means.
3.Attempt to suspend again.

Actual results:
On second attempt, suspend fails. Machine locks and must be forcibly powered down.

Expected results:
Suspend and resume as normal--just as worked back in Fedora 25.

Additional info:
I am running Fedora on an Acer C710 Chromebook flashed with John Lewis's open source SeaBios. It had worked perfectly with Fedora for several years before this.
============================
Note: Why is Component name a required field on this form? How the hell to I know what component is involved? I'm reporting aberrent behavior, I do not have, and do not want, access to the code.
=============================

Comment 1 Ricardo Alonso 2018-04-11 15:59:47 UTC
*** Bug 1566152 has been marked as a duplicate of this bug. ***

Comment 2 Ricardo Alonso 2018-07-09 07:55:27 UTC
This problem is not been observed anymore on F28. It seams to have been corrected. 

Those are the versions: 

$ cat /etc/redhat-release 
Fedora release 28 (Twenty Eight)
$ uname -a
Linux r1.ricardoalonso.local 4.17.2-200.fc28.x86_64 #1 SMP Mon Jun 18 20:09:31 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Comment 3 Justin M. Forbes 2018-07-23 15:34:19 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 27 kernel bugs.

Fedora 27 has now been rebased to 4.17.7-100.fc27.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 28, and are still experiencing this issue, please change the version to Fedora 28.

If you experience different issues, please open a new bug report for those.

Comment 4 Justin M. Forbes 2018-08-29 15:24:03 UTC
*********** MASS BUG UPDATE **************
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in 5 weeks. If you are still experiencing this issue, please reopen and attach the relevant data from the latest kernel you are running and any data that might have been requested previously.


Note You need to log in before you can comment on or make changes to this bug.