Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515561 - OpsUI - MyServices - Credentials do not show - for providers other than VMware provider
Summary: OpsUI - MyServices - Credentials do not show - for providers other than VMwar...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Harpreet Kataria
QA Contact: Shveta
URL:
Whiteboard:
: 1526604 (view as bug list)
Depends On:
Blocks: 1526081
TreeView+ depends on / blocked
 
Reported: 2017-11-21 03:35 UTC by Kedar Kulkarni
Modified: 2018-06-21 20:30 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1526081 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:30:09 UTC
Category: Bug
Cloudforms Team: CFME Core
kkulkarn: automate_bug+


Attachments (Terms of Use)
Screenshot (deleted)
2017-11-21 03:35 UTC, Kedar Kulkarni
no flags Details

Description Kedar Kulkarni 2017-11-21 03:35:47 UTC
Created attachment 1356355 [details]
Screenshot

Description of problem:
In reference to bug[1], the Credentials currently are only shown for VMware provider, but for other providers, credentials not shown.

[1]https://bugzilla.redhat.com/show_bug.cgi?id=1444092

Version-Release number of selected component (if applicable):
5.9.0.9

How reproducible:
100%

Steps to Reproduce:
1. create a set of vmware credentials
2. create a service backed by a playbook that set it to use the vmware credentials.
3. order the service

Actual results:
When the service is viewed in my services, the credentials section only lists the default machine credentials.

Expected results:
It should also show that the Provider credentials were attached to the service.

Additional info:

Comment 12 CFME Bot 2017-12-13 22:43:41 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/f93b03cf522815b8619d5549c9e0cbe6b3dcd80c

commit f93b03cf522815b8619d5549c9e0cbe6b3dcd80c
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Dec 13 17:02:47 2017 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Dec 13 17:02:47 2017 -0500

    Made changes to show Cloud credentials on service summary screen
    
    - And made all credentials values as clickable links.
    - Removed VMware Credentials code, as those fall under Cloud Credentials, dont need to show them separately.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1515561

 app/helpers/service_helper/textual_summary.rb | 27 +++++++++++++--------------
 1 file changed, 13 insertions(+), 14 deletions(-)

Comment 14 Harpreet Kataria 2017-12-21 13:48:04 UTC
*** Bug 1526604 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.