Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515502 - Impossible to edit an existing Service Dialog element
Summary: Impossible to edit an existing Service Dialog element
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: cfme-future
Assignee: Roman Blanco
QA Contact: Shveta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 23:00 UTC by Jerome Marc
Modified: 2017-12-05 15:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-04 12:55:06 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)
saving modified dialog (deleted)
2017-11-21 12:40 UTC, Roman Blanco
no flags Details
Service Dialog generated from Ansible with edit issue (deleted)
2017-11-22 19:54 UTC, Jerome Marc
no flags Details

Description Jerome Marc 2017-11-20 23:00:27 UTC
Description of problem:
It is impossible to save changes on a Service Dialog element. User has to delete the existing element and recreate it in order to be able to save the service dialog.

Version-Release number of selected component (if applicable):
5.9.0.9.20171115202245_7429f75

How reproducible:
always

Steps to Reproduce:
1. Edit an element on an existing service dialog (e.g. change the label)
2. Try to save

Actual results:
It is impossible to save.

Expected results:
The change should be saved.

Additional info:

Comment 2 Roman Blanco 2017-11-21 12:40:47 UTC
Created attachment 1356668 [details]
saving modified dialog

I've tried and I'm not able to reproduce the bug.

Jerome, could you check the attachment if I'm doing something wrong?

Thanks, Roman.

Comment 3 Jerome Marc 2017-11-22 19:54:12 UTC
I was able to edit a newly created service dialog. However, the issue is still occurring when trying to edit a service dialog generated from an Ansible Service.

I have attached an example of a dialog with the issue.

Comment 4 Jerome Marc 2017-11-22 19:54:51 UTC
Created attachment 1357786 [details]
Service Dialog generated from Ansible with edit issue


Note You need to log in before you can comment on or make changes to this bug.