Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515446 - build.gluster.org times out and does not load!
Summary: build.gluster.org times out and does not load!
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 19:37 UTC by Shyamsundar
Modified: 2018-01-22 09:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-22 09:46:52 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shyamsundar 2017-11-20 19:37:06 UTC
Description of problem:

When attempting to access https://build.gluster.org, the following error appears after a minute or so attempting to load the page.

"
Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /index.html.

Reason: Error reading from remote server
"

An earlier instance of the same was mentioned as the "java heap error" causing the problem. It is possibly the same.

Comment 1 M. Scherer 2017-11-21 01:56:11 UTC
Yup, jenkins was out, I restarted it, but it did fail 5 minutes after I disconnected for the evening. I did also add some swap since I suspect that's the root cause of the issue.

Comment 2 Nigel Babu 2017-11-21 03:11:07 UTC
I had to restart again. Can we bump up the RAM to 8 GB, please?

Comment 3 Nigel Babu 2018-01-22 09:46:52 UTC
Turns out this was due to some bots spidering some Jenkins pages pretty aggressively. Once I kicked them off, the stability has increased greatly. Closing for now.


Note You need to log in before you can comment on or make changes to this bug.