Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515436 - gnome-shell crashes with attached stacktrace: FcConfigEvaluate at top of stack.
Summary: gnome-shell crashes with attached stacktrace: FcConfigEvaluate at top of stack.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 19:24 UTC by Nick Dokos
Modified: 2018-04-23 11:31 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-20 12:05:19 UTC


Attachments (Terms of Use)
stacktrace of gnome-shell crash. (deleted)
2017-11-20 19:24 UTC, Nick Dokos
no flags Details

Description Nick Dokos 2017-11-20 19:24:14 UTC
Created attachment 1356104 [details]
stacktrace of gnome-shell crash.

Description of problem:

I run Fedora 26 on a Lenovo Thinkpad W541. I ran a "dnf update" last Friday (2017-11-17) and after the update I could not login with any Gnome choice: Gnome, Gnome Classic, or Gnome on X11 - after a couple of burps on the display, it would return to the login prompt. I installed the cinnamon desktop and was able to log in with that.

It turns out that gnome-shell crashes in FcConfigEvaluate - see attached stacktrace.

Version-Release number of selected component (if applicable):
fontconfig.x86_64                                  2.12.6-4.fc26                                  @updates

How reproducible:
Always.

Steps to Reproduce:
1. dnf update
2. reboot
3. login

Actual results:
Churn a bit and then return to the login screen.

Expected results:
Successful login.

Additional info:

Comment 1 Akira TAGOH 2017-12-13 09:51:41 UTC
try with debuginfo please. that stacktrace isn't quite useful.

Comment 2 Nick Dokos 2018-02-09 21:00:26 UTC
I updated to F27 and can no longer reproduce this. Might as well close it.

Comment 3 Pooja Yadav 2018-02-20 12:05:19 UTC
Not reproducible on F27, therefore closing this.


Note You need to log in before you can comment on or make changes to this bug.