Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515434 - dht_(f)xattrop does not implement migration checks
Summary: dht_(f)xattrop does not implement migration checks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.13
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On: 1471031 1530146 1540224
Blocks: glusterfs-3.13.0
TreeView+ depends on / blocked
 
Reported: 2017-11-20 19:16 UTC by Shyamsundar
Modified: 2018-01-30 13:59 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.13.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1471031
Environment:
Last Closed: 2018-01-23 21:37:19 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shyamsundar 2017-11-20 19:16:17 UTC
+++ This bug was initially created as a clone of Bug #1471031 +++

Description of problem:

Sharding uses xattrops to set the size info on the file. DHT does not currently implement migration phase1/phase2 checks for these and can possibly lead to issues when sharding is enabled.

Comment 1 Worker Ant 2018-01-03 05:09:25 UTC
REVIEW: https://review.gluster.org/19126 (cluster/dht: Add migration checks to dht_(f)xattrop) posted (#1) for review on release-3.13 by N Balachandran

Comment 2 Worker Ant 2018-01-09 13:57:32 UTC
COMMIT: https://review.gluster.org/19126 committed in release-3.13 by \"N Balachandran\" <nbalacha@redhat.com> with a commit message- cluster/dht: Add migration checks to dht_(f)xattrop

The dht_(f)xattrop implementation did not implement
migration phase1/phase2 checks which could cause issues
with rebalance on sharded volumes.
This does not solve the issue where fops may reach the target
out of order.

> Change-Id: I2416fc35115e60659e35b4b717fd51f20746586c
> BUG: 1471031
> Signed-off-by: N Balachandran <nbalacha@redhat.com>

Change-Id: I2416fc35115e60659e35b4b717fd51f20746586c
BUG: 1515434
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 3 Worker Ant 2018-01-10 08:46:12 UTC
REVIEW: https://review.gluster.org/19175 (cluster/dht: Add migration checks to dht_(f)xattrop) posted (#1) for review on release-3.13 by N Balachandran

Comment 4 Worker Ant 2018-01-16 20:16:07 UTC
COMMIT: https://review.gluster.org/19175 committed in release-3.13 by \"N Balachandran\" <nbalacha@redhat.com> with a commit message- cluster/dht: Add migration checks to dht_(f)xattrop

The earlier backport was incorrect. Added the missing
lines of code.

The dht_(f)xattrop implementation did not implement
migration phase1/phase2 checks which could cause issues
with rebalance on sharded volumes.
This does not solve the issue where fops may reach the target
out of order.

> Change-Id: I2416fc35115e60659e35b4b717fd51f20746586c
> BUG: 1471031
> Signed-off-by: N Balachandran <nbalacha@redhat.com>

BUG: 1515434
Change-Id: I183d52530e0220e3007e73672991cb79b44c022a
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 5 Shyamsundar 2018-01-23 21:37:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.2, please open a new bug report.

glusterfs-3.13.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-January/000089.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.