Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515433 - "Save" button appears instead of "Submit"
Summary: "Save" button appears instead of "Submit"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: GA
: 5.10.0
Assignee: Harpreet Kataria
QA Contact: Angelina Nikiforova
URL:
Whiteboard:
: 1517836 (view as bug list)
Depends On:
Blocks: 1517887
TreeView+ depends on / blocked
 
Reported: 2017-11-20 19:16 UTC by Shmuel Melamud
Modified: 2019-04-02 08:24 UTC (History)
8 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1517887 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:18:20 UTC
Category: Bug
Cloudforms Team: RHEVM


Attachments (Terms of Use)

Description Shmuel Melamud 2017-11-20 19:16:09 UTC
Description of problem:

I'm working on this service dialog:
https://github.com/ManageIQ/manageiq-providers-ovirt/blob/master/content/service_dialogs/transform-vm.yml

After updating to the latest master the following issue appeared: when I use the dialog, 'Save' button appears instead of 'Submit' button. Pressing the 'Save' button does not submit the dialog as before, but displays "Save Button not yet implemented" message.

The dialog is actually wired to a real button in the UI. Not a service or custom button.

The yaml file says:

---
- description: Transform VM
  buttons: submit,cancel
  label: Transform VM
  dialog_tabs:

But actually save/reset/cancel buttons are displayed.

How reproducible:
100%

Steps to Reproduce:
1. Open VM list in the CFME UI.
2. Select Lifecycle > Transform VM

Actual results:
Dialog with save/reset/cancel buttons is displayed.

Expected results:
Dialog with submit/cancel buttons is displayed.


Additional info:

Comment 2 Shmuel Melamud 2017-11-20 19:19:58 UTC
This issue is urgent since it blocks further work on the V2V functionality.

Comment 5 Harpreet Kataria 2017-11-21 15:55:00 UTC
https://github.com/ManageIQ/manageiq-ui-classic/pull/2785

Comment 6 CFME Bot 2017-11-21 23:18:31 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/8d49676a1fbfe05ac9f3562a3cf5bf30deee6f23

commit 8d49676a1fbfe05ac9f3562a3cf5bf30deee6f23
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Nov 21 10:51:38 2017 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Nov 21 10:51:38 2017 -0500

    Added missing classes to list APPLIES_TO_CLASS_BASE_MODELS
    
    Added code back that was removed during refactoring to show different set of buttons when running a Dialog thru a custom button in VM explorer.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1515433
    Issue #2754

 app/controllers/application_controller/buttons.rb |  4 ++--
 app/controllers/vm_common.rb                      | 10 +++++++++-
 2 files changed, 11 insertions(+), 3 deletions(-)

Comment 8 Harpreet Kataria 2017-11-27 23:00:51 UTC
*** Bug 1517836 has been marked as a duplicate of this bug. ***

Comment 9 Tsai Li Ming 2018-05-28 06:22:55 UTC
I am still getting this issue on 5.9.2.4.20180501195858_35dc609

Comment 10 Tsai Li Ming 2018-05-28 06:27:55 UTC
It appears Save for a dialog box that has been added as a Button to the Service. 

Under SSUI, it works with the "Submit Request" button.

Comment 11 Tsai Li Ming 2018-06-01 10:39:40 UTC
*** Bug 1584804 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.