Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515429 - XWayland hangs when adding bookmark to firefox 57 with firefox account
Summary: XWayland hangs when adding bookmark to firefox 57 with firefox account
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 19:05 UTC by Paul DeStefano
Modified: 2017-11-24 22:25 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-24 22:25:15 UTC


Attachments (Terms of Use)

Description Paul DeStefano 2017-11-20 19:05:58 UTC
Description of problem:
After updating to firefox 57, XWayland freezes immediately when clicking the bookmark button to add a bookmark.  I can move the mouse, but I cannot move windows or switch focus (follow focus) and I cannot interact with any window, including FF.  This lasts for about 5-10 seconds.  Then, window service is restored, but FF is using more than 200% CPU (two processes >100%) for about 60 seconds.  I think this is firefox sync service.

Version-Release number of selected component (if applicable):
firefox-57.0-2.fc26.x86_64

How reproducible:
Always since FF57

Steps to Reproduce:
1. F26
2. Setup firefox sync
3. upgrade firefox
4. make a new bookmark

Actual results:
XWayland temporarily freezes/hangs

Expected results:


Additional info:

Comment 1 Martin Stransky 2017-11-20 19:31:39 UTC
Can you please attach a backtrace when firefxo freezes as per:

https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Application_freeze

Thanks!

Comment 2 Paul DeStefano 2017-11-20 21:51:49 UTC
I'm not sure I can, actually.  It's not a crash; the freeze is only temporary, and it's all of XWayland, so I cannot force a crash with gdb as I cannot take any actions with the computer during the freeze.

But, I quit and restarted firefox, and now I don't see this behavior.  So, let me see how this goes for the rest of the week and I'll update this bug.

Comment 3 Paul DeStefano 2017-11-24 22:25:15 UTC
I haven't seen this since restarting firefox.  I don't know why that would be, but I think I'll close this bug.  I suppose I can always reopen it later if it recurs.


Note You need to log in before you can comment on or make changes to this bug.