Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515428 - DVB cards with SAA7146 chips not detected
Summary: DVB cards with SAA7146 chips not detected
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 26
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: x86Tracker
TreeView+ depends on / blocked
 
Reported: 2017-11-20 19:03 UTC by Ronald
Modified: 2018-03-19 15:14 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-19 15:14:28 UTC


Attachments (Terms of Use)

Description Ronald 2017-11-20 19:03:59 UTC
Description of problem: DVB cards with SAA7146 chips are not detected


Version-Release number of selected component (if applicable):
Kernel-PAE 4.13.x (tested with 4.13.5, 4.13.9, 4.13.10, 4.13.12)
Works correctly with Kernel-PAE 4.11.8


How reproducible:
100%


Steps to Reproduce:
1. Boot my system with Kernel-PAE 4.13.x
2. Check /dev/dvb for adapters
3. Find out that adapters are not there.

Actual results:
DVB Adapters are not available


Expected results:
DVB Adapters are available


Additional info:
/var/log/messages contains the following related stack trace:

Nov 17 15:22:58 phoenix kernel: ------------[ cut here ]------------
Nov 17 15:22:58 phoenix kernel: kernel BUG at drivers/media/common/saa7146/saa7146_core.c:163!
Nov 17 15:22:58 phoenix kernel: invalid opcode: 0000 [#1] SMP
Nov 17 15:22:58 phoenix kernel: Modules linked in: rc_technisat_ts35 tda10023 crc32_pclmul snd_hda_codec_realtek tda10021 snd_hda_codec_generic snd_hda_codec_hdmi snd_hda_intel snd_hda_codec joydev snd_hda_core budget_av(+) saa7146_vv vid
eobuf_dma_sg snd_hwdep videobuf_core budget_core ttpci_eeprom saa7146 k10temp v4l2_common videodev media snd_seq mantis mantis_core dvb_core rc_core snd_seq_device snd_pcm snd_timer snd soundcore sp5100_tco tpm_tis tpm_tis_core video tpm
i2c_piix4 acpi_cpufreq ata_generic pata_acpi radeon hid_logitech_hidpp crc32c_intel i2c_algo_bit drm_kms_helper alx mdio ttm pata_atiixp drm hid_logitech_dj
Nov 17 15:22:58 phoenix kernel: CPU: 0 PID: 461 Comm: systemd-udevd Not tainted 4.13.12-200.fc26.i686+PAE #1
Nov 17 15:22:58 phoenix kernel: Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./FM2A88X Extreme4+, BIOS P2.10 01/17/2014
Nov 17 15:22:59 phoenix kernel: task: ef791280 task.stack: f67b4000
Nov 17 15:22:59 phoenix kernel: EIP: saa7146_vmalloc_build_pgtable+0x180/0x1010 [saa7146]
Nov 17 15:22:59 phoenix kernel: EFLAGS: 00010246 CPU: 0
Nov 17 15:22:59 phoenix kernel: EAX: f5654a40 EBX: f5f76800 ECX: 00000002 EDX: ffa9b000
Nov 17 15:22:59 phoenix kernel: ESI: 00000000 EDI: f82f2000 EBP: f67b5c50 ESP: f67b5c2c
Nov 17 15:22:59 phoenix kernel:  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
Nov 17 15:22:59 phoenix kernel: CR0: 80050033 CR2: b7c74ff0 CR3: 364ad8c0 CR4: 000406f0
Nov 17 15:22:59 phoenix kernel: Call Trace:
Nov 17 15:22:59 phoenix kernel:  ttpci_budget_init+0x26c/0x530 [budget_core]
Nov 17 15:22:59 phoenix kernel:  budget_av_attach+0x75/0xcd1 [budget_av]
Nov 17 15:22:59 phoenix kernel:  ? vprintk_func+0x29/0x70
Nov 17 15:22:59 phoenix kernel:  ? via_no_dac+0x40/0x40
Nov 17 15:22:59 phoenix kernel:  ? printk+0x13/0x15
Nov 17 15:22:59 phoenix kernel:  ? saa7146_init_one+0x69f/0x810 [saa7146]
Nov 17 15:23:00 phoenix kernel:  saa7146_init_one+0x776/0x810 [saa7146]
Nov 17 15:23:00 phoenix kernel:  ? __pm_runtime_resume+0x51/0x80
Nov 17 15:23:00 phoenix kernel:  pci_device_probe+0xc2/0x160
Nov 17 15:23:00 phoenix kernel:  driver_probe_device+0x2b9/0x410
Nov 17 15:23:00 phoenix kernel:  __driver_attach+0x99/0xe0
Nov 17 15:23:01 phoenix kernel:  ? driver_probe_device+0x410/0x410
Nov 17 15:23:01 phoenix kernel:  bus_for_each_dev+0x57/0x90
Nov 17 15:23:01 phoenix kernel:  driver_attach+0x19/0x20
Nov 17 15:23:01 phoenix kernel:  ? driver_probe_device+0x410/0x410
Nov 17 15:23:01 phoenix kernel:  bus_add_driver+0x187/0x230
Nov 17 15:23:01 phoenix kernel:  ? 0xf83e2000
Nov 17 15:23:01 phoenix kernel:  driver_register+0x56/0xd0
Nov 17 15:23:01 phoenix kernel:  ? 0xf83e2000
Nov 17 15:23:01 phoenix kernel:  __pci_register_driver+0x33/0x40
Nov 17 15:23:01 phoenix kernel:  saa7146_register_extension+0x50/0x80 [saa7146]
Nov 17 15:23:02 phoenix kernel:  budget_av_init+0xd/0x1000 [budget_av]
Nov 17 15:23:03 phoenix kernel:  do_one_initcall+0x46/0x170
Nov 17 15:23:03 phoenix kernel:  ? kfree+0x134/0x150
Nov 17 15:23:03 phoenix kernel:  ? kfree+0x134/0x150
Nov 17 15:23:03 phoenix kernel:  ? kmem_cache_alloc_trace+0x155/0x1c0
Nov 17 15:23:03 phoenix kernel:  ? do_init_module+0x21/0x1cc
Nov 17 15:23:03 phoenix kernel:  ? do_init_module+0x21/0x1cc
Nov 17 15:23:04 phoenix kernel:  do_init_module+0x50/0x1cc
Nov 17 15:23:04 phoenix kernel:  load_module+0x23cb/0x29e0
Nov 17 15:23:04 phoenix kernel:  SyS_init_module+0x135/0x170
Nov 17 15:23:04 phoenix kernel:  do_fast_syscall_32+0x71/0x150
Nov 17 15:23:04 phoenix kernel:  entry_SYSENTER_32+0x4e/0x7c
Nov 17 15:23:04 phoenix kernel: EIP: 0xb7f3acf9
Nov 17 15:23:04 phoenix kernel: EFLAGS: 00000246 CPU: 0
Nov 17 15:23:04 phoenix kernel: EAX: ffffffda EBX: 019e3500 ECX: 00008703 EDX: b7eaa0f1
Nov 17 15:23:04 phoenix kernel: ESI: b7e9e3a4 EDI: 0196bf78 EBP: 019e3500 ESP: bf87cda0
Nov 17 15:23:04 phoenix kernel:  DS: 007b ES: 007b FS: 0000 GS: 0033 SS: 007b
Nov 17 15:23:04 phoenix kernel: Code: e4 e8 b5 eb ff ff 85 c0 59 75 6b 8b 45 ec 8d 65 f4 5b 5e 5f 5d c3 90 8d 74 26 00 83 3d 70 db cf d5 02 0f 85 09 ff ff ff 8d 76 00 <0f> 0b 8d b6 00 00 00 00 0f 0b 8d b6 00 00 00 00 c7 45 dc 00 00
Nov 17 15:23:04 phoenix kernel: EIP: saa7146_vmalloc_build_pgtable+0x180/0x1010 [saa7146] SS:ESP: 0068:f67b5c2c
Nov 17 15:25:39 phoenix kernel: random: get_random_bytes called from start_kernel+0x35/0x41d with crng_init=0
Nov 17 15:25:39 phoenix kernel: Linux version 4.13.12-200.fc26.i686+PAE (mockbuild@bkernel02.phx2.fedoraproject.org) (gcc version 7.2.1 20170915 (Red Hat 7.2.1-2) (GCC)) #1 SMP Wed Nov 8 17:09:43 UTC 2017
Nov 17 15:25:39 phoenix kernel: x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers'
Nov 17 15:25:39 phoenix kernel: x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers'
Nov 17 15:25:39 phoenix kernel: x86/fpu: Supporting XSAVE feature 0x004: 'AVX registers'
Nov 17 15:25:39 phoenix kernel: x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256
Nov 17 15:25:39 phoenix kernel: x86/fpu: Enabled xstate features 0x7, context size is 832 bytes, using 'standard' format.
Nov 17 15:25:39 phoenix kernel: e820: BIOS-provided physical RAM map:
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009e7ff] usable
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000000009e800-0x000000000009ffff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x0000000000100000-0x000000007ba84fff] usable
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000007ba85000-0x000000007bab4fff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000007bab5000-0x000000007bd76fff] usable
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000007bd77000-0x000000007be30fff] ACPI NVS
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000007be31000-0x000000007e134fff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000007e135000-0x000000007e135fff] usable
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000007e136000-0x000000007e33bfff] ACPI NVS
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000007e33c000-0x000000007e491fff] usable
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000007e492000-0x000000007f02efff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000007f02f000-0x000000007f071fff] usable
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000007f072000-0x000000007f7f0fff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x000000007f7f1000-0x000000007f7fffff] usable
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x00000000fec10000-0x00000000fec10fff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x00000000fed00000-0x00000000fed00fff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x00000000fed40000-0x00000000fed44fff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x00000000fed80000-0x00000000fed8ffff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x00000000ff800000-0x00000000ffffffff] reserved
Nov 17 15:25:39 phoenix kernel: BIOS-e820: [mem 0x0000000100000000-0x000000023effffff] usable

Comment 1 Thomas 2018-02-09 11:14:23 UTC
I have the same problem on ubuntu with kernels above 4.11, so I opened a bug report here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1742316

Seems to be a bug in the mainline kernel since commit 19809c2da28aee5860ad9a2eff760730a0710df0

Discussion is going on here: https://lkml.org/lkml/2018/2/8/19

Comment 2 Ronald 2018-03-17 13:02:21 UTC
The problem is resolved since kernel 4.15.7 (should also work with 4.15.6 but could not test in depth with this kernel because of another issue)

Comment 3 Laura Abbott 2018-03-19 15:14:28 UTC
Thanks for letting us know, I'm going to close the bug for now, feel free to reopen if the problem shows up again.


Note You need to log in before you can comment on or make changes to this bug.