Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515349 - 10gig test fails; ifdowns all ports and doesn't bring them back.
Summary: 10gig test fails; ifdowns all ports and doesn't bring them back.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-hardware
Version: 1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: brose
QA Contact: rhcert qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 16:14 UTC by Nathan LeBarron
Modified: 2018-01-02 21:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1515437 (view as bug list)
Environment:
Last Closed: 2018-01-02 21:59:07 UTC


Attachments (Terms of Use)

Description Nathan LeBarron 2017-11-20 16:14:04 UTC
Description of problem:


Version-Release number of selected component (if applicable):
RHEL7.3 (73z kernel) RHCERTkit version 5.3

How reproducible:Always


Steps to Reproduce:
1.install OS and testkit
2. bring up gige and 10gig network
3. run test
4. test fails

Actual results: Fail:
<output name="TCP-throughput" description="tcp throughput test via lmbench">
testing bandwidth to 137.38.91.198
testing these number of threads: [2, 4, 8, 16]
Using 2 threads:
bw_tcp -P 2 -m 1m 137.38.91.198
<command command="bw_tcp -P 2 -m 1m 137.38.91.198" return-value="0" signal="0"><stderr>connect: No route to host</stderr></command>
Error: tcp bandwidth test failed
bw_tcp errors: connect: No route to host
"bw_tcp -P 2 -m 1m 137.38.91.198" ['connect: No route to host']
<summary data-value="FAIL">FAIL</summary>
</output>
<output name="UDP" description="udp latency test via lmbench">
testing udp latency to 137.38.91.198...
<command command="lat_udp 137.38.91.198" return-value="0" signal="0"><stderr>Recv timed out</stderr></command>
['Recv timed out']
<summary data-value="PASS">PASS</summary>
</output>
<output name="HTTP" description="HTTP file transfer test">
<command command="dd if=/dev/urandom of=/var/www/html/httptest.file bs=128k count=1250" return-value="0" signal="0"><stderr>1250+0 records in
1250+0 records out
163840000 bytes (164 MB) copied, 12.0691 s, 13.6 MB/s</stderr></command>
sending file /var/www/html/httptest.file hash: bcac83bc8c93ccd47c6bed3cb3cf4ce0
<command command="curl -i -X POST -F &quot;file=@/var/www/html/httptest.file;type=text/foo&quot; &quot;http://137.38.91.198/save&quot;" return-value="7" signal="0"><regex single-line="False">.*</regex><stderr>  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
  0     0    0     0    0     0      0      0 --:--:--  0:00:02 --:--:--     0
  0     0    0     0    0     0      0      0 --:--:--  0:00:03 --:--:--     0curl: (7) Failed connect to 137.38.91.198:80; No route to host</stderr></command>
Error: Exception raised in test hwcert/network/Ethernet/10GigEthernet:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/rhcert/client/harness.py", line 1173, in runTest
    rv = test.run()
  File "/usr/lib/python2.7/site-packages/rhcert/suites/hwcert/hwcert/networkTest.py", line 753, in run
    if not self.runSubTest(self.httpTransferTest, "HTTP", "HTTP file transfer test"):
  File "/usr/lib/python2.7/site-packages/rhcert/test.py", line 390, in runSubTest
    result = subtestFunction()
  File "/usr/lib/python2.7/site-packages/rhcert/suites/hwcert/hwcert/networkTest.py", line 529, in httpTransferTest
    (sentFileCheckSum, uploadIPAddress) = self.httpUpload()
  File "/usr/lib/python2.7/site-packages/rhcert/suites/hwcert/hwcert/networkTest.py", line 559, in httpUpload
    response = '\n'.join(curlCommand.getStringList(regex=".*", ignoreErrors=True))
  File "/usr/lib/python2.7/site-packages/rhcert/command.py", line 214, in getStringList
    result = self._getString(regex, regexGroup, singleLine=False, returnList=True)
  File "/usr/lib/python2.7/site-packages/rhcert/command.py", line 210, in _getString
    raise HwCertCommandException(self, "no match for regular expression %s" % self.regex)
HwCertCommandException: "curl -i -X POST -F "file=@/var/www/html/httptest.file;type=text/foo" "http://137.38.91.198/save"" no match for regular expression .*



Expected results: Test Pass


Additional info:
There is no information in the test instructions on how these network ports are supposed to be configured.

Right now we have:
> > TS:
> >
> > gige 137.38.91.198  > to switch
> >
> > 10gig 137.38.91.199  > to SUT2 10gig
> 
> > SUT:
> >
> > gige  137.38.91.197> to switch
> >
> > 10gig 137.38.91.221 > to TS 10gig
> 

In this configuration we get a failure every time due to the 10gig ports not being up.

Comment 1 Frank Ramsay 2018-01-02 19:57:11 UTC
This cert is complete, we can close this


Note You need to log in before you can comment on or make changes to this bug.