Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515326 - Error after canceling editing Chargeback rate
Summary: Error after canceling editing Chargeback rate
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: Hilda Stastna
QA Contact: Nandini Chandra
URL:
Whiteboard:
: 1515323 (view as bug list)
Depends On:
Blocks: 1515478
TreeView+ depends on / blocked
 
Reported: 2017-11-20 15:14 UTC by Hilda Stastna
Modified: 2018-06-21 20:31 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1515478 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:31:28 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Hilda Stastna 2017-11-20 15:14:50 UTC
Description of problem:
Error after canceling editing Chargeback rate when clicking on Cancel button for the second time. Error occurs because Cancel button is still present and clickable more times than once in a row.

Version-Release number of selected component (if applicable):
5.9

How reproducible:
always

Steps to Reproduce:
1. Go to Cloud Intel -> Chargeback
2. Choose Rates tab
3. Create a new rate if there is no one
4. Choose some rate
5. In Configuration choose Edit this Chargeback Rate
6. Click on Cancel button as you wish to cancel editing
7. Cancel button is still there! Click on it again => error!


Actual results:
F, [2017-10-30T17:45:18.884740 #25241] FATAL -- : Error caught: [NoMethodError] undefined method `[]' for nil:NilClass
/home/hstastna/manageiq/manageiq-ui-classic/app/controllers/chargeback_controller.rb:101:in `cb_rate_edit'


Expected results:
Buttons Save, Reset and Cancel should not be there after clicking on Save or Cancel button when canceling editing some Chargeback rate. No error should appear in log.


Additional info:
The problem also occurs when you successfully edit the rate, click Save and then Cancel. Cancel button and others (but unclickable) are still there!

Comment 3 Hilda Stastna 2017-11-20 15:27:46 UTC
*** Bug 1515323 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.