Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515318 - Event for finished "ImportCluster" task is not send via snmp or email
Summary: Event for finished "ImportCluster" task is not send via snmp or email
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-notifier
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 14:53 UTC by Martin Bukatovic
Modified: 2017-11-21 08:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-21 07:12:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1515662 None None None Never

Internal Links: 1515662

Description Martin Bukatovic 2017-11-20 14:53:05 UTC
Description of problem
======================

Event for finished "ImportCluster" task is not send via snmp or email.

Such functionality is not part of requirements, but on the other hand
it's not clear if it's intentional.

Version-Release
===============

# rpm -qa | grep tendrl | sort
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-commons-1.5.4-3.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-4.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-4.el7rhgs.noarch
tendrl-node-agent-1.5.4-3.el7rhgs.noarch
tendrl-notifier-1.5.4-2.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-ui-1.5.4-3.el7rhgs.noarch

How reproducible
================

100 %

Steps to Reproduce
==================

1. Install RHGS WA using tendrl-ansible
2. Configure alerting to send events via both smtp and snmp
3. Import gluster trusted storage pool with a volume
4. See alerts/events send shown via UI and send via smtp and snmp

When qe playbooks for alerting test setup are used:

* https://github.com/usmqe/usmqe-setup/blob/master/test_setup.smtp.yml
* https://github.com/usmqe/usmqe-setup/blob/master/test_setup.snmp.yml

one can check incoming snmp trap messages via:

# journalctl -u snmptrapd -fe

and email messages via:

# mutt

Actual results
==============

I see event in the ui:

> Job finished successfully (job_id: f26ac520-f1e9-4758-b2

but there is no SNMPv3 message received about this nor there is
email message for it.

Expected results
================

There is snmp trap message received via snmptrapd daemon
and email about the same is send.

Additional info
===============

Based on documentation of alerting:

https://github.com/Tendrl/documentation/wiki/List-of-Alerts-and-Notifications-in-Tendrl

sending job finished event for ImportCluster job is not listed there,
neither it's part of requirements.

For this reason, I'm marking this as low priority and ask dev and PMs to
evaluate.

Comment 2 Nishanth Thomas 2017-11-21 07:05:17 UTC
Only Alert conditions are notified. Alert conditions are listed on the notifications drawer. If something which are listed there and not notified, then its a bug. This is as per design and not a bug.

Also I don't think 'job' finished is something which falls into the category of alert conditions, which will flood the mailbox of the administrator.
http://10.70.41.241

Comment 3 RHEL Product and Program Management 2017-11-21 07:12:40 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 4 Martin Bukatovic 2017-11-21 08:12:34 UTC
(In reply to Nishanth Thomas from comment #2)
> Only Alert conditions are notified. Alert conditions are listed on the
> notifications drawer. If something which are listed there and not notified,
> then its a bug. This is as per design and not a bug.
> 
> Also I don't think 'job' finished is something which falls into the category
> of alert conditions, which will flood the mailbox of the administrator.

Ack. Thank you for the clarification. I have created a doc BZ to make sure we
have this documented, see BZ 1515662


Note You need to log in before you can comment on or make changes to this bug.