Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515291 - systemctl reload kills gluster integration daemon
Summary: systemctl reload kills gluster integration daemon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-gluster-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: Bala Konda Reddy M
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 14:09 UTC by Martin Kudlej
Modified: 2018-01-15 09:06 UTC (History)
6 users (show)

Fixed In Version: tendrl-gluster-integration-1.5.4-4.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:37:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Red Hat Bugzilla 1517156 None None None Never
Github Tendrl gluster-integration issues 491 None None None 2017-11-21 05:48:48 UTC

Internal Links: 1517156

Description Martin Kudlej 2017-11-20 14:09:12 UTC
Description of problem:
Configuration reloading of gluster integration daemon kills it.

Version-Release number of selected component (if applicable):
tendrl-gluster-integration-1.5.4-3.el7rhgs.noarch

How reproducible:
100%

Steps to Reproduce:
1. daemon is running - systemctl status tendrl-gluster-integration
2. reload configuration - systemctl reload tendrl-gluster-integration
3. daemon is down - systemctl status tendrl-gluster-integration

Actual results:
Configuration reloading of gluster integration daemon kills it.

Expected results:
Configuration reloading of gluster integration daemon will reload daemon configuration:
/usr/share/tendrl/gluster-integration/gluster-integration.conf.yaml

Comment 2 Rohan Kanade 2017-11-21 05:47:56 UTC
systemctl reload is used for reloading configurations for the service.

Fixed: https://github.com/Tendrl/gluster-integration/issues/491

Comment 4 Petr Penicka 2017-11-21 12:10:09 UTC
Giving all acks for 3.3.1 after call confirming this fix is going into today's build.

Comment 9 errata-xmlrpc 2017-12-18 04:37:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.