Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515283 - OSPd12 - passed_phase1 - /etc/default/grub is missing
Summary: OSPd12 - passed_phase1 - /etc/default/grub is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director-images
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 12.0 (Pike)
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 13:54 UTC by Eyal Dannon
Modified: 2017-12-13 20:03 UTC (History)
9 users (show)

Fixed In Version: rhosp-director-images-12.0-20171121.3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 20:03:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3459 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 director images Enhancement Advisory 2017-12-14 01:03:02 UTC

Description Eyal Dannon 2017-11-20 13:54:51 UTC
Description of problem:
While deploying OSPD12 passed_phase1
The deployment fails on:

(undercloud) [root@panther07 ~]# heat deployment-show 39169592-4a18-4870-85dd-990bc673b532
WARNING (shell) "heat deployment-show" is deprecated, please use "openstack software deployment show" instead
{
  "status": "FAILED",
  "server_id": "308440c9-4337-4098-b35d-1903e9b7c90e",
  "config_id": "30346de4-5824-4ecc-97eb-dc14fe96f020",
  "output_values": {
    "deploy_stdout": "\nPLAY [Configuration to be applied before rebooting the node] *******************\n\nTASK [Gathering Facts] *********************************************************\nok: [localhost]\n\nTASK [Ensure the kernel args ( default_hugepagesz=1GB hugepagesz=1G hugepages=32 iommu=pt intel_iommu=on ) is present as TRIPLEO_HEAT_TEMPLATE_KERNEL_ARGS] ***\nfatal: [localhost]: FAILED! => {\"changed\": false, \"failed\": true, \"msg\": \"Destination /etc/default/grub does not exist !\", \"rc\": 257}\n\tto retry, use: --limit @/var/lib/heat-config/heat-config-ansible/30346de4-5824-4ecc-97eb-dc14fe96f020_playbook.retry\n\nPLAY RECAP *********************************************************************\nlocalhost                  : ok=1    changed=0    unreachable=0    failed=1   \n\n",
    "deploy_stderr": "",
    "deploy_status_code": 2
  },
  "creation_time": "2017-11-20T10:18:21Z",
  "updated_time": "2017-11-20T10:22:45Z",
  "input_values": {
    "_TUNED_PROFILE_NAME_": "cpu-partitioning",
    "_TUNED_CORES_": "1,2,3,8,9,10,11,12,13,14,15,16,17,18,19,24,25,26,27,28,29,30,31",
    "_KERNEL_ARGS_": "default_hugepagesz=1GB hugepagesz=1G hugepages=32 iommu=pt intel_iommu=on"
  },
  "action": "CREATE",
  "status_reason": "deploy_status_code : Deployment exited with non-zero status code: 2",
  "id": "39169592-4a18-4870-85dd-990bc673b532"


Which does not included at overcloud-full.qcow2
[root@panther07 tmp]# virt-ls -a overcloud-full.qcow2 /etc/default/
nss
useradd



Version-Release number of selected component (if applicable):
OSPD12 -      
http://download-node-02.eng.bos.redhat.com/rcm-guest/puddles/OpenStack/12.0-RHEL-7/passed_phase1/

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
Does not exists

Expected results:
Should exists

Additional info:

Comment 1 Alex Schultz 2017-11-21 21:59:10 UTC
Please provide templates and logs. The grub configuration is not part of the overcloud image and is part the host config that should be applied as part of the deployment.

Comment 6 Mike Burns 2017-11-22 05:48:33 UTC
dropping needinfo since we have the issue root-caused and fix identified.

Comment 8 Thierry Vignaud 2017-11-22 10:39:58 UTC
Patch has landed in git and will be in next images set

Comment 11 Jon Schlueter 2017-11-28 05:22:59 UTC
internal change broke functionality and then was resolved no release notes required

Comment 12 Omri Hochman 2017-11-30 19:56:59 UTC
Verified with rhosp-director-images-12.0-20171129.1.el7ost.noarch

exist on OC_Nodes :
[root@overcloud-controller-0 ~]# rpm -qa | grep grub
grub2-pc-modules-2.02-0.65.el7_4.2.noarch
grub2-tools-2.02-0.65.el7_4.2.x86_64
grub2-pc-2.02-0.65.el7_4.2.x86_64
grub2-common-2.02-0.65.el7_4.2.noarch
grub2-tools-minimal-2.02-0.65.el7_4.2.x86_64
grub2-tools-extra-2.02-0.65.el7_4.2.x86_64
grub2-efi-x64-modules-2.02-0.65.el7_4.2.noarch
grub2-efi-x64-2.02-0.65.el7_4.2.x86_64
grubby-8.28-23.el7.x86_64
grub2-2.02-0.65.el7_4.2.x86_64

[root@overcloud-controller-0 ~]# cat /etc/default/grub
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="console=tty0 console=ttyS0,115200n8 crashkernel=auto rhgb quiet"
GRUB_DISABLE_RECOVERY="true"

Comment 15 errata-xmlrpc 2017-12-13 20:03:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3459


Note You need to log in before you can comment on or make changes to this bug.