Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515271 - [RFE]node-agent - doesn't reload configuration
Summary: [RFE]node-agent - doesn't reload configuration
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-node-agent
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 13:19 UTC by Martin Kudlej
Modified: 2018-12-07 10:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-07 10:48:00 UTC


Attachments (Terms of Use)

Description Martin Kudlej 2017-11-20 13:19:19 UTC
Description of problem:
"systemctl reload" command doesn't reload node-agent configuration.

Version-Release number of selected component (if applicable):
tendrl-node-agent-1.5.4-3.el7rhgs.noarch

How reproducible:
100%

Steps to Reproduce:
1. get current date: $ date
2. get conf files for package: $ rpm -qc tendrl-node-agent
3. reload configuration: $ systemctl reload tendrl-node-agent
4. check if conf files from 2. are touched: $ find /etc/tendrl/ -type f | xargs stat | egrep '^Access: 2|File:'

Actual results:
"systemctl reload" doesn't reload service configuration.

Expected results:
"systemctl reload" reloads service configuration.

Additional info:
Cite from systemd documentation:
reload PATTERN...
           Asks all units listed on the command line to reload their
           configuration. Note that this will reload the service-specific
           configuration, not the unit configuration file of systemd. If you
           want systemd to reload the configuration file of a unit, use the
           daemon-reload command. In other words: for the example case of
           Apache, this will reload Apache's httpd.conf in the web server,
           not the apache.service systemd unit file.

           This command should not be confused with the daemon-reload
           command.

Comment 1 Rohan Kanade 2017-11-21 13:10:31 UTC
I would prefer if you make some changes to the config file and then test this.

Comment 3 gowtham 2018-08-29 07:35:01 UTC
I have tested notifier component, I gave the wrong etcd hostname in notifier configuration file /etc/tendrl/notifier/notifier.conf.yaml. And tried command "systemctl reload tendrl-notifier". After a few seconds notifier logged message like " Error connecting to central store (etcd), trying again..." and stopped executing.

It is actually reloading when there any changes in a configuration file if you did not change anything in configuration file then reload change the touch date and time.

In above case you have not changed anything in a configuration file, So it clearly says this bug is misunderstood and not valid.

Comment 4 Shubhendu Tripathi 2018-11-20 13:01:15 UTC
Based on https://bugzilla.redhat.com/show_bug.cgi?id=1515271#c3 shouldnt this be closed as NOTABUG?

Comment 5 gowtham 2018-11-22 06:53:40 UTC
This is not a bug, we can close this

Comment 6 Nishanth Thomas 2018-12-07 10:48:00 UTC
Not planing to fix this in any of the upcoming releases. Closing the BZ


Note You need to log in before you can comment on or make changes to this bug.