Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515268 - monitoring - doesn't reload configuration
Summary: monitoring - doesn't reload configuration
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Rohan Kanade
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 13:16 UTC by Martin Kudlej
Modified: 2018-08-14 11:15 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
When the user runs 'systemctl reload' the monitoring integration configuration does not reload. To work around this issue, run 'systemctl restart'. Monitoring integration restarts as part of this operation and the configuration is done.
Clone Of:
Environment:
Last Closed: 2018-04-26 06:07:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github Tendrl gluster-integration issues 491 None None None 2017-11-21 12:59:51 UTC

Description Martin Kudlej 2017-11-20 13:16:01 UTC
Description of problem:
"systemctl reload" command doesn't reload monitoring configuration. It returns error.

Version-Release number of selected component (if applicable):
tendrl-monitoring-integration-1.5.4-4.el7rhgs.noarch

How reproducible:
100%

Steps to Reproduce:
1. get current date: $ date
2. get conf files for package: $ rpm -qc tendrl-monitoring-integration
3. reload configuration: $ systemctl reload tendrl-monitoring-integration
step 3 returns error: Job for tendrl-monitoring-integration.service invalid.
it it pass then we can continue to step 4.
4. check if conf files from 2. are touched: $ find /etc/tendrl/ -type f | xargs stat | egrep '^Access: 2|File:'

Actual results:
"systemctl reload" doesn't reload service configuration and returns error.

Expected results:
"systemctl reload" reloads service configuration.

Additional info:
Cite from systemd documentation:
reload PATTERN...
           Asks all units listed on the command line to reload their
           configuration. Note that this will reload the service-specific
           configuration, not the unit configuration file of systemd. If you
           want systemd to reload the configuration file of a unit, use the
           daemon-reload command. In other words: for the example case of
           Apache, this will reload Apache's httpd.conf in the web server,
           not the apache.service systemd unit file.

           This command should not be confused with the daemon-reload
           command.

Comment 1 Rohan Kanade 2017-11-21 12:59:51 UTC
Fixed: https://github.com/Tendrl/gluster-integration/issues/491

Comment 4 Lubos Trilety 2017-11-28 11:48:02 UTC
Tested with:
tendrl-monitoring-integration-1.5.4-8.el7rhgs.noarch

There's no error when reload is made.
However changes in configuration files are not reloaded. Access time on those configuration files is not changed and just to be sure I changed some settings (e.g. etcd port) without any change in behaviour of the service.

Comment 6 Lubos Trilety 2017-12-05 15:03:43 UTC
Tested with:
tendrl-monitoring-integration-1.5.4-11.el7rhgs.noarch

When I tried change configuration first time there was an error in log, however the service is still running, which should not. It should behave similarly like when it is run with the bad configuration (goes to failed state and stop).
Moreover when I tried that again there was no error in log just line with this sentence 'Reloaded Monitoring Integration'.

Comment 12 Nishanth Thomas 2017-12-07 04:21:21 UTC
Moving the bug out of 3.3.z


Note You need to log in before you can comment on or make changes to this bug.