Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515205 - [REGRESSION] Brightness not able to be controlled on Lenovo P50
Summary: [REGRESSION] Brightness not able to be controlled on Lenovo P50
Keywords:
Status: CLOSED DUPLICATE of bug 1511786
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 11:49 UTC by Pete Savage
Modified: 2018-03-19 11:27 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-28 16:07:31 UTC
kherbst: needinfo-


Attachments (Terms of Use)

Description Pete Savage 2017-11-20 11:49:42 UTC
Description of problem: Brightness not able to be controlled in on Lenovo P50

Version-Release number of selected component (if applicable): Fedora25/26 Kernel 4.13.11+


How reproducible: 100%


Steps to Reproduce:
1. Use Fedora25/26 with the latest kernel
2.
3.

Actual results: Brightness in gnome is no longer controllable


Expected results: Brightness hsould be able to be controlled


Additional info: This used to work on older kernel image 4.13.5

Comment 1 Pete Savage 2017-11-20 11:50:49 UTC
It should be noted that the BIOS was set to Discrete graphics only

Comment 2 Jeremy Cline 2017-11-20 14:46:52 UTC
Hey,

Thank you for the bug report. Did this work in 4.13.10 and first appear in 4.13.11, or did it break sometime between 4.13.5 and 4.13.11? If the latter is true, could you narrow down which stable release introduced the regression?

The old kernel builds are available on Koji: https://koji.fedoraproject.org/koji/packageinfo?packageID=8

Thanks!

Comment 3 Pete Savage 2018-01-08 13:22:18 UTC
I think this is a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1511786

Comment 4 Laura Abbott 2018-02-28 03:45:59 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.

Comment 5 Pete Savage 2018-02-28 12:37:50 UTC
I believe there is a fix for this, Karol?

Comment 6 Laura Abbott 2018-02-28 16:07:31 UTC
I'm just going to mark as a duplicate

*** This bug has been marked as a duplicate of bug 1511786 ***


Note You need to log in before you can comment on or make changes to this bug.