Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515172 - cannot upgrade with a custom download directory
Summary: cannot upgrade with a custom download directory
Keywords:
Status: CLOSED DUPLICATE of bug 1513823
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: 26
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 10:19 UTC by Domenico Ferrari
Modified: 2017-11-30 10:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-30 10:01:00 UTC


Attachments (Terms of Use)

Description Domenico Ferrari 2017-11-20 10:19:48 UTC
Description of problem:
dnf system-upgrade doesn't upgrade if packages are downloaded with "--downloaddir" 

Steps to Reproduce:
1. dnf system-upgrade --releasever 27 --downloaddir /mnt/disk1/sysup --downloadonly
2. dnf system-upgrade reboot

Actual results:
Upgrade starts but after a few seconds the system reboots and starts in Fedora 26

Expected results:
System completes upgrade and starts in Fedora 27

Additional info:
dnf system-upgrade log doesn't show any logs and I can't find other logs.
I modified the systemd startup script to remove "reboot" after the process complete and I saw an error about connecting to mirror site.
I proceeded by adding "-C" to the script and I saw a bunch of errors about checksum failures cause system-upgrade is searching for packages in the default location and not in the directory provided on the command line.
On the same system I was able to upgrade using default download directory, not using --downloaddir and --downloadonly options

Comment 1 Marek Blaha 2017-11-30 10:01:00 UTC

*** This bug has been marked as a duplicate of bug 1513823 ***


Note You need to log in before you can comment on or make changes to this bug.