Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515162 - Octavia.conf is not properly configured
Summary: Octavia.conf is not properly configured
Keywords:
Status: CLOSED DUPLICATE of bug 1506644
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-octavia
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 12.0 (Pike)
Assignee: Or Idgar
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 09:52 UTC by Alexander Stafeyev
Modified: 2017-12-06 13:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 13:30:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 487450 None None None 2017-11-30 12:31:48 UTC

Description Alexander Stafeyev 2017-11-20 09:52:47 UTC
Description of problem:
The following should be part of [api_settings] and not [DEFAULT]:

bind_host=172.17.1.15
bind_port=9876
auth_strategy=keystone

+
Health manager configs are not set

[health_manager]
# bind_ip = 127.0.0.1
# bind_port = 5555
# controller_ip_port_list example: 127.0.0.1:5555, 127.0.0.1:5555
# controller_ip_port_list =

Version-Release number of selected component (if applicable):
RHOS 12 


How reproducible:
100

Steps to Reproduce:
Deploy cloud with octavia (ospd)

Comment 1 Nir Magnezi 2017-11-20 10:14:54 UTC
Alex, please specify the RPM versions you tested.

Comment 3 Carlos Goncalves 2017-11-20 12:31:39 UTC
It comes from pupper-octavia and it was fixed in upstream master branch [1] after stable/pike [2]

[1] https://github.com/openstack/puppet-octavia/blob/master/manifests/api.pp#L83
[2] https://github.com/openstack/puppet-octavia/blob/stable/pike/manifests/api.pp#L88

Comment 4 Nir Magnezi 2017-11-20 12:32:04 UTC
Carlos tracked a possible fix that we should backport: https://review.openstack.org/#/c/503985/

Comment 6 Or Idgar 2017-11-30 12:31:49 UTC
Already fixed in openstack gerrit 487450 patch.
Waiting to finish testing this patch then we will merge it.

Comment 7 Nir Magnezi 2017-12-06 13:30:33 UTC
Already covered by bug 1506644
See bug 1506644 comment 6

*** This bug has been marked as a duplicate of bug 1506644 ***


Note You need to log in before you can comment on or make changes to this bug.