Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515161 - Memory leak in locks xlator
Summary: Memory leak in locks xlator
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: locks
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1517682 1517689 1517692
TreeView+ depends on / blocked
 
Reported: 2017-11-20 09:52 UTC by Xavi Hernandez
Modified: 2018-03-15 11:21 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1517682 1517689 1517692 (view as bug list)
Environment:
Last Closed: 2018-03-15 11:21:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2017-11-20 09:52:09 UTC
Description of problem:

There are memory leaks of strings created with gf_strdup() in features/locks xlator.

Version-Release number of selected component (if applicable): master


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2017-11-20 09:55:05 UTC
REVIEW: https://review.gluster.org/18812 (features/locks: Fix memory leaks) posted (#1) for review on master by Xavier Hernandez

Comment 2 Worker Ant 2017-11-22 10:13:23 UTC
COMMIT: https://review.gluster.org/18812 committed in master by \"Xavier Hernandez\" <jahernan@redhat.com> with a commit message- features/locks: Fix memory leaks

Change-Id: Ic1d2e17a7d14389b6734d1b88bd28c0a2907bbd6
BUG: 1515161
Signed-off-by: Xavier Hernandez <jahernan@redhat.com>

Comment 3 Shyamsundar 2018-03-15 11:21:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.