Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 151516 - system-config-network crashes at startup
Summary: system-config-network crashes at startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-18 21:13 UTC by Ville Skyttä
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-12 06:51:15 UTC


Attachments (Terms of Use)
bug-buddy backtrace from system-config-network (deleted)
2005-03-18 21:13 UTC, Ville Skyttä
no flags Details

Description Ville Skyttä 2005-03-18 21:13:14 UTC
Launching system-config-network (1.3.23-1) crashes before the GUI appears.  No
core file, info from bug-buddy attached.

System info: ThinkPad A30p, one 100Mb interface (eth0, not in use, cable
unplugged), one Compaq WL110 11Mb PCMCIA wireless card (eth1, in use, works
fine).  KDE.

Bug 150449 looks similar, but not quite the same.  I have rhpl-0.157-1.

/var/lib/pcmcia/stab is:
Socket 0: Intersil PRISM2 11 Mbps Wireless Adapter
0       network orinoco_cs      0       eth1
Socket 1: unsupported card

(Socket 1 is a Omnikey CardMan 4000 smart card reader)

Comment 1 Ville Skyttä 2005-03-18 21:13:14 UTC
Created attachment 112141 [details]
bug-buddy backtrace from system-config-network

Comment 2 Harald Hoyer 2005-03-22 09:33:48 UTC
could you please install the rhpl-debuginfo rpm and rerun s-c-network?

Comment 3 Ville Skyttä 2005-03-22 16:13:43 UTC
I already had it at the time I reported this.  Without it installed,
"get_module" is not in the backtrace generated by bug-buddy at all, and it looks
in many ways much less informative too.

The problem is the same as in bug 150449 in the sense that no matter what I do,
no core file is produced.  ulimit -c is unlimited.  The messages on console are
practically the same as in bug 150449, comment 1.

When I generate the backtrace with bug-buddy, I get this on the console:
** (bug-buddy:21855): WARNING **: Couldn't load icon for Evince Document Viewer
"/usr/sbin/system-config-network": not in executable format: File format not
recognized
Variable "eno" is not available.


Comment 4 Ville Skyttä 2005-04-02 19:53:25 UTC
The segfault seems to be fixed in rhpl-0.158-1.

However, now I get lots of this on the console while s-c-n is running:

    Warning : Device eth1 has been compiled with version 17
    of Wireless Extension, while we are using version 16.
    Some things may be broken...


Comment 5 Harald Hoyer 2005-04-04 15:34:53 UTC
$  fgrep WIRELESS_EXT /usr/include/linux/wireless.h
#define WIRELESS_EXT    16
        __u8            we_version_compiled;    /* Must be WIRELESS_EXT */
$ rpm -qf /usr/include/linux/wireless.h
glibc-kernheaders-2.4-9.1.90

feel free to open a new bug for this, or rename and reassign

Comment 6 Ville Skyttä 2005-04-12 06:51:15 UTC
New: bug 154490


Note You need to log in before you can comment on or make changes to this bug.