Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515089 - Cluster Id is not showing up properly, when navigated from volumes widget from the dashboard
Summary: Cluster Id is not showing up properly, when navigated from volumes widget fro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ui
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: Rochelle
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 06:41 UTC by Bala Konda Reddy M
Modified: 2017-12-18 04:37 UTC (History)
6 users (show)

Fixed In Version: tendrl-monitoring-integration-1.5.4-5.el7rhgs.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:37:36 UTC


Attachments (Terms of Use)
Under cluster id, it is showing clusterid+clusterid (deleted)
2017-11-20 06:41 UTC, Bala Konda Reddy M
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Github https://github.com/Tendrl monitoring-integration issues 279 None None None 2017-11-21 05:54:36 UTC

Description Bala Konda Reddy M 2017-11-20 06:41:58 UTC
Created attachment 1355525 [details]
Under cluster id, it is showing clusterid+clusterid

Description of problem:

Navigating from the Tendrl-Gluster-at-glance to tendrl-gluster-volumes from volumes widget. The cluster id is not showing up properly

Version-Release number of selected component (if applicable):
tendrl-ui-1.5.4-3

How reproducible:
everytime

Steps to Reproduce:
1. On the imported cluster, Navigate to dashboard
2. Click on the tooltip of volumes on the gluster-at-a-glance page. It navigates to tendrl-gluster-volumes page.
3. Check the cluster Id

Actual results:
The clustered is shown as "70909321-86fb-443a-9625-90d6588100fb+70909321-86fb-443a-9625-90d6588100fb"


Expected results:
The cluster id should be shown as "70909321-86fb-443a-9625-90d6588100fb", it should not show + again the cluster id

Additional info:

Please the find the attachment

Comment 3 Petr Penicka 2017-11-20 13:26:22 UTC
Giving pm_ack and 3.3.z+ since both qa_ack and dev_ack are already given.

Comment 4 Ankush Behl 2017-11-21 05:54:36 UTC
Fixed: https://github.com/Tendrl/monitoring-integration/issues/279

Comment 6 Rochelle 2017-11-22 08:44:02 UTC
Navigating from the Tendrl-Gluster-at-glance to tendrl-gluster-volumes from volumes widget, the clusterid's are showing up as expected.

Moving this bug to verified

Comment 9 errata-xmlrpc 2017-12-18 04:37:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.