Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515027 - NetworkManager-wait-online.service completes too early when device has no carrier for unusually long time
Summary: NetworkManager-wait-online.service completes too early when device has no car...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.2
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: sushil kulkarni
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-20 01:58 UTC by Akshay Jain
Modified: 2018-04-10 13:35 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 13:34:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
[PATCH] device: make carrier-wait-timeout configurable per device (deleted)
2017-11-21 14:53 UTC, Thomas Haller
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0778 None None None 2018-04-10 13:35:11 UTC

Description Akshay Jain 2017-11-20 01:58:35 UTC
Description of problem:

NetworkManager-wait-online.service is occasionally completing (aka Started) before network connectivity is established, thus allowing systemd to reach the network-online.target before connectivity has been established.

Customer use autofs and LDAP heavily and depend on the network connectivity being established before those services are brought up. When network connectivity is not up and autofs is started, the host is unable to properly boot.

Version-Release number of selected component (if applicable):
NetworkManager-1.8.0-9.el7.x86_64
autofs-5.0.7-54.px5.el7.x86_64


How reproducible:
Activate NetworkManager-wait-online.service and boot.


Additional info:
 if customer override the NetworkManager-wait-online.service to execute `ExecStart=/usr/bin/nm-online --timeout 30` instead of `ExecStart=/usr/bin/nm-online -s --timeout 30`, the issue no longer occurs.


We have a bug open on upstream with same issue.
https://bugzilla.redhat.com/show_bug.cgi?id=1483343

Comment 2 Thomas Haller 2017-11-21 14:53:00 UTC
Created attachment 1356761 [details]
[PATCH] device: make carrier-wait-timeout configurable per device

Comment 6 Vladimir Benes 2018-02-14 10:43:16 UTC
working well in CI now

Comment 9 errata-xmlrpc 2018-04-10 13:34:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0778


Note You need to log in before you can comment on or make changes to this bug.