Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514985 - fedora 26->27 fails during dnf upgrade
Summary: fedora 26->27 fails during dnf upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ima-evm-utils
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Bruno Meneguele
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-19 21:20 UTC by diakula
Modified: 2017-11-28 23:51 UTC (History)
5 users (show)

Fixed In Version: ima-evm-utils-1.0-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-28 23:51:27 UTC


Attachments (Terms of Use)

Description diakula 2017-11-19 21:20:49 UTC
Description of problem:
Attempting an install with dnf fails with:

When downloading, at the transaction check I get:
Error: Transaction check error:
  file /usr/share/man/man1/evmctl.1.gz conflicts between attempted installs of ima-evm-utils-1.0-1.fc27.i686 and ima-evm-utils-1.0-1.fc27.x86_64

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. dnf system-upgrade download --releasever=27
2.
3.

Actual results:
download passes
key importing passes
transaction check passes
transaction test fails with

Error: Transaction check error:
  file /usr/share/man/man1/evmctl.1.gz conflicts between attempted installs of ima-evm-utils-1.0-1.fc27.i686 and ima-evm-utils-1.0-1.fc27.x86_64

 

Expected results:
success, reboot to install

Additional info:

Comment 1 Vivek Goyal 2017-11-20 13:52:48 UTC
Bruno, assigning it to you as primarily you are taking care of ima-evm-utils package now.

Comment 2 Bruno Meneguele 2017-11-20 14:21:58 UTC
Hi Vivek, 

yes, sure. I'll take a look ASAP. 
Thanks!

Comment 4 Fedora Update System 2017-11-20 21:06:23 UTC
ima-evm-utils-1.0-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0fdf615c08

Comment 5 Bruno Meneguele 2017-11-20 21:13:58 UTC
Hi dialuka,

the problem was that you were trying to install both x86_64 and i686 versions of the package and the manpage evmctl.1.gz had a bug in its setup. A solution was already applied and a new package is being made and will be available soon in the official repo (after some days of testing).

But while in testing phase could you test the following packages:
i686: https://kojipkgs.fedoraproject.org//packages/ima-evm-utils/1.0/2.fc27/i686/ima-evm-utils-1.0-2.fc27.i686.rpm
x86_64: https://kojipkgs.fedoraproject.org//packages/ima-evm-utils/1.0/2.fc27/x86_64/ima-evm-utils-1.0-2.fc27.x86_64.rpm

and give us some feedback about the installation process? The idea is the same, install them through the normal "sudo dnf install <package-path>" command and check if something fails.

Anyway, thank you very much for the report!

Comment 7 Fedora Update System 2017-11-22 06:31:37 UTC
ima-evm-utils-1.0-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-0fdf615c08

Comment 8 Fedora Update System 2017-11-28 23:51:27 UTC
ima-evm-utils-1.0-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.