Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514962 - libvirt unable to start network[Duplicate] of https://bugzilla.redhat.com/show_bug.cgi?id=1514963
Summary: libvirt unable to start network[Duplicate] of https://bugzilla.redhat.com/sho...
Keywords:
Status: CLOSED DUPLICATE of bug 1514963
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-19 17:48 UTC by dravigon
Modified: 2017-11-19 23:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-19 23:26:47 UTC


Attachments (Terms of Use)

Description dravigon 2017-11-19 17:48:33 UTC
Description of problem:
unable to start a network with bandwidth description for outbound
my xml for network

<network>
  <name>sda</name>
  <uuid>173997d2-61b6-4425-a852-8f07a877f75f</uuid>
  <forward dev='enp3s0' mode='nat'>
    <nat>
      <port start='1024' end='2048'/>
    </nat>
    <interface dev='enp3s0'/>
  </forward>
  <bridge name='virbr0' stp='on' delay='0'/>
  <mac address='52:54:00:90:cb:d0'/>
  <domain name='sda'/>
  <bandwidth>
    <inbound average='50' peak='50' burst='50'/>
    <outbound average='50' peak='50' burst='50'/>
  </bandwidth>
  <ip address='192.100.0.12' netmask='255.255.255.0'>
  </ip>
</network>


Version-Release number of selected component (if applicable):libvirt 3.9.0


How reproducible:100%


Steps to Reproduce:
1.create a network with nat mode and with bandwith outbound rule in Qos
2.start the network


Actual results:
libvirt:  error : internal error: Child process (/usr/bin/tc filter add dev virbr0 parent ffff: protocol all u32 match u32 0 0 police rate 50kbps burst 50kb mtu 64kb drop flowid :1) unexpected exit status 1: What is ":1"?
Usage: ... u32 [ match SELECTOR ... ] [ link HTID ] [ classid CLASSID ]
               [ action ACTION_SPEC ] [ offset OFFSET_SPEC ]
               [ ht HTID ] [ hashkey HASHKEY_SPEC ]
               [ sample SAMPLE ] [skip_hw | skip_sw]
or         u32 divisor DIVISOR

Where: SELECTOR := SAMPLE SAMPLE ...
       SAMPLE := { ip | ip6 | udp | tcp | icmp | u{32|16|8} | mark }
                 SAMPLE_ARGS [ divisor DIVISOR ]
       FILTERID := X:Y:Z

NOTE: CLASSID is parsed at hexadecimal input.
libvirt: Network Driver error : Network not found: no network with matching uuid 'a734e030-f800-4b72-a077-f360134bdc13' (sda)


Expected results:
Network must start automatically

Additional info:
qemu version :2.10.0
dnsmasq is installed

Comment 1 Cole Robinson 2017-11-19 23:26:47 UTC

*** This bug has been marked as a duplicate of bug 1514963 ***


Note You need to log in before you can comment on or make changes to this bug.