Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514955 - /usr/include/spa/props.h:29:10: fatal error: spa/pod-parser.h: No such file or directory
Summary: /usr/include/spa/props.h:29:10: fatal error: spa/pod-parser.h: No such file o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pipewire
Version: 27
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Wim Taymans
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1519731 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-19 17:08 UTC by Knut J BJuland
Modified: 2017-12-12 11:22 UTC (History)
2 users (show)

Fixed In Version: pipewire-0.1.6-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 11:22:25 UTC


Attachments (Terms of Use)
Add imssing pod-parser.h to pipewire-devel (deleted)
2017-12-01 17:53 UTC, Robert Mader
no flags Details | Diff

Description Knut J BJuland 2017-11-19 17:08:35 UTC
Description of problem:

/usr/include/spa/props.h:29:10: fatal error: spa/pod-parser.h: No such file or directory
Version-Release number of selected component (if applicable):

0.1.6
How reproducible:
every time

Steps to Reproduce:
1. download mutter f27 from git
2 rebuild mutter with --enable-egl-device
2.
3.

Actual results:
In file included from /usr/include/spa/node.h:34:0,
                 from /usr/include/pipewire/port.h:31,
                 from /usr/include/pipewire/core.h:45,
                 from /usr/include/pipewire/client.h:47,
                 from /usr/include/pipewire/pipewire.h:29,
                 from backends/meta-screen-cast.c:27:
/usr/include/spa/props.h:29:10: fatal error: spa/pod-parser.h: No such file or directory
 #include <spa/pod-parser.h>
          ^~~~~~~~~~~~~~~~~~
compilation terminated.
make[4]: *** [Makefile:2416: backends/meta-screen-cast.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
In file included from /usr/include/spa/node.h:34:0,
                 from /usr/include/pipewire/port.h:31,
                 from /usr/include/pipewire/core.h:45,
                 from /usr/include/pipewire/client.h:47,
                 from /usr/include/pipewire/pipewire.h:29,
                 from backends/meta-screen-cast-stream-src.c:28:
/usr/include/spa/props.h:29:10: fatal error: spa/pod-parser.h: No such file or directory
 #include <spa/pod-parser.h>
          ^~~~~~~~~~~~~~~~~~
compilation terminated.
make[4]: *** [Makefile:2416: backends/meta-screen-cast-stream-src.lo] Error 1
make[4]: Leaving directory '/home/knutjb/rpmbuild/BUILD/mutter-3.26.2/src'
make[3]: *** [Makefile:2588: all-recursive] Error 1
make[3]: Leaving directory '/home/knutjb/rpmbuild/BUILD/mutter-3.26.2/src'
make[2]: *** [Makefile:1508: all] Error 2
make[2]: Leaving directory '/home/knutjb/rpmbuild/BUILD/mutter-3.26.2/src'
make[1]: *** [Makefile:484: all-recursive] Error 1
make[1]: Leaving directory '/home/knutjb/rpmbuild/BUILD/mutter-3.26.2'
make: *** [Makefile:414: all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.9hO0Re (%build)


RPM build errors:
    bogus date in %changelog: Wed Sep 21 2017 Florian Müllner <fmuellner@redhat.com> - 3.26.0-5
    Bad exit status from /var/tmp/rpm-tmp.9hO0Re (%build)
knutjb@knut:~/rpmbuild/SPECS$ 


Expected results:
should build

Additional info:

Comment 1 Knut J BJuland 2017-11-19 17:11:00 UTC
/usr/include/spa$ ls
audio      command-node.h  event-node.h      hook.h  loop.h     param-alloc.h  pod.h        ringbuffer.h
buffer.h   defs.h          format-builder.h  lib     meta.h     param.h        pod-iter.h   type.h
clock.h    dict.h          format.h          list.h  monitor.h  plugin.h       pod-utils.h  type-map.h
command.h  event.h         format-utils.h    log.h   node.h     pod-builder.h  props.h      video
knutjb@knut:/usr/include/spa$

Comment 2 Knut J BJuland 2017-11-26 19:50:35 UTC
I fixed the error by copying from the source srpm to /usr/include/spa/pod-parser.h

Comment 3 Robert Mader 2017-12-01 17:31:09 UTC
*** Bug 1519731 has been marked as a duplicate of this bug. ***

Comment 4 Robert Mader 2017-12-01 17:53:51 UTC
Created attachment 1361713 [details]
Add imssing pod-parser.h to pipewire-devel

This add the missing file to the devel package, making it possible again to build dependent packages like mutter

Comment 5 Fedora Update System 2017-12-04 11:13:46 UTC
pipewire-0.1.6-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5dae859131

Comment 6 Fedora Update System 2017-12-08 23:26:54 UTC
pipewire-0.1.6-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5dae859131

Comment 7 Fedora Update System 2017-12-12 11:22:25 UTC
pipewire-0.1.6-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.