Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514932 - RHV 4.1.8 engine upgrade to 4.2.0-6 fails with missing rpm dependency
Summary: RHV 4.1.8 engine upgrade to 4.2.0-6 fails with missing rpm dependency
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: distribution
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Aviv Sabadra
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-19 14:36 UTC by Eyal Edri
Modified: 2017-12-11 12:47 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-28 12:08:24 UTC
oVirt Team: Rel-Eng


Attachments (Terms of Use)
/var/log/ovirt-engine logs attached (deleted)
2017-11-19 14:38 UTC, Eyal Edri
no flags Details

Description Eyal Edri 2017-11-19 14:36:06 UTC
Description of problem:
Upgrade from a clean 4.1.8 to latest downstream build of 4.2.0-6 fails on:

     --== PACKAGES ==--
         
          Configure ovirt-provider-ovn (Yes, No) [Yes]: 
[ INFO  ] Checking for product updates...
[ ERROR ] Yum [u'resteasy-base-jaxrs-3.0.6-4.el7.noarch requires mvn(org.scannotation:scannotation)']
[ INFO  ] Yum Performing yum transaction rollback
[ ERROR ] Failed to execute stage 'Environment customization': [u'resteasy-base-jaxrs-3.0.6-4.el7.noarch requires mvn(org.scannotation:scannotation)']
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20171119161103-ebssth.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20171119161120-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Install latest 4.1.8 build from bob ( yum install + engine-setup )
2.Install 4.2.0-6 release rpm to get 4.2.0 repos
2.yum update ovirt-engine-setup
3.run again engine-setup to do the upgrade

Actual results:
engine setup fails on missing 
 Yum [u'resteasy-base-jaxrs-3.0.6-4.el7.noarch requires mvn(org.scannotation:scannotation)']

Expected results:
engine-setup should pass

Additional info:
Looks like an issue of JBOSS 7.0->7.1 upgrade?

Comment 1 Eyal Edri 2017-11-19 14:38:41 UTC
Created attachment 1355177 [details]
/var/log/ovirt-engine logs attached

Comment 4 Sandro Bonazzola 2017-11-24 15:02:21 UTC
resteasy-base-jaxrs-3.0.6-4.el7.noarch comes from outside RHV channels, moving to release engineering.

Comment 5 Aviv Sabadra 2017-11-27 09:05:06 UTC
is it still an issue? I don't see anything broken but can further investigate if needed.

Comment 6 RHV Bugzilla Automation and Verification Bot 2017-11-27 09:44:02 UTC
I wasn't able to reproduce it on CI or manual testing,
Nelly, have you encountered any issues with upgrade from 4.1.8 to 4.2?

Comment 7 Nelly Credi 2017-11-27 14:36:35 UTC
No ovirt issues.
we did have some issue with eap, need to investigate, 
but this is when doing 'yum update', 
with your steps there are no problems

Comment 8 Yaniv Kaul 2017-11-28 12:08:24 UTC
Closing. Please re-open if reproduced. 
I assume (Nelly - please verify) that QE are testing upgrades from latest 4.1.z to 4.2.0.

Comment 9 Nelly Credi 2017-12-11 12:47:56 UTC
I havent seen this issue in the automation


Note You need to log in before you can comment on or make changes to this bug.