Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514925 - vdsm-client Host getVMFullList returns "vmName": "nNone" and not the real VM name
Summary: vdsm-client Host getVMFullList returns "vmName": "nNone" and not the real VM ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: General
Version: 4.20.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.2.0
: 4.20.9.3
Assignee: Francesco Romani
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-19 13:49 UTC by Raz Tamir
Modified: 2017-12-20 10:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:51:26 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84343 master MERGED vm: keep reporting 'vmName' 2017-11-20 10:00:13 UTC

Description Raz Tamir 2017-11-19 13:49:18 UTC
Description of problem:
When executing vdsm-client Host getVMFullList I get for a VM I have - "vmName": "nNone" and not the actual VM name


Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20171116212005.git61ffb5f.el7.centos
vdsm-4.20.7-34.gitab15536.el7.centos.x86_64
vdsm-client-4.20.7-34.gitab15536.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Start VM on host
2. Run 'vdsm-client Host getVMFullLis' on host
3.

Actual results:


Expected results:


Additional info:

Comment 1 Raz Tamir 2017-11-19 13:57:43 UTC
Regression flag:
We use vmName in our automation to identify the VM and it used to work fine

Comment 2 Yaniv Kaul 2017-11-19 14:11:36 UTC
Raz, if there are vdsm-client commands you use for automation and are critical, let me know so we can add them to ovirt-system-tests.

Comment 3 Yaniv Kaul 2017-11-19 14:12:00 UTC
(In reply to Yaniv Kaul from comment #2)
> Raz, if there are vdsm-client commands you use for automation and are
> critical, let me know so we can add them to ovirt-system-tests.

Or better yet, add them yourself :-)

Comment 4 Raz Tamir 2017-11-19 14:16:01 UTC
Sure,

will do

Comment 5 Dan Kenigsberg 2017-11-19 14:53:31 UTC
Alternatively, how about migrating automation code to libvirt; e.g.

  virsh -r list

would show currently-running names of VMs.

Comment 6 Red Hat Bugzilla Rules Engine 2017-11-19 14:53:37 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 7 Raz Tamir 2017-11-19 15:07:57 UTC
We actually need more information on the VM like IP, disk logical names, etc. which is not provided be virsh -r list.

Of course, we can workaround this issue, otherwise, I would mark it as urgent, but I don't think this is the correct approach

Comment 8 Francesco Romani 2017-11-19 16:56:23 UTC
(In reply to Raz Tamir from comment #7)
> We actually need more information on the VM like IP, disk logical names,
> etc. which is not provided be virsh -r list.
> 
> Of course, we can workaround this issue, otherwise, I would mark it as
> urgent, but I don't think this is the correct approach

Vdsm does not report anymore this information for any VM created with the Domain XML - as per Engine >= 4.2 defaults (it does if VM is created with vm.conf, as Engine <= 4.1 does)

Some informations are easy to provide, and we can evaluate to do that to give time to the automated tools to catch up.

Please provide the fields you need. Fixing 'vmName' meanwhile.

Comment 9 Francesco Romani 2017-11-19 16:57:04 UTC
(In reply to Francesco Romani from comment #8)
> (In reply to Raz Tamir from comment #7)
> > We actually need more information on the VM like IP, disk logical names,
> > etc. which is not provided be virsh -r list.
> > 
> > Of course, we can workaround this issue, otherwise, I would mark it as
> > urgent, but I don't think this is the correct approach
> 
> Vdsm does not report anymore this information for any VM created with the
> Domain XML - as per Engine >= 4.2 defaults (it does if VM is created with
> vm.conf, as Engine <= 4.1 does)
> 
> Some informations are easy to provide, and we can evaluate to do that to
> give time to the automated tools to catch up.
> 
> Please provide the fields you need. Fixing 'vmName' meanwhile.

I forgot to mention that the output of 'getAllVmStats' is unchanged, and always the same regardless the VM is created.

Comment 10 Raz Tamir 2017-11-19 17:12:30 UTC
I tested few other fields we use in our automation and seems like this is the only issue

Comment 11 Francesco Romani 2017-11-20 08:50:15 UTC
If we agree this is a regression, then this doesn't deserve any doc_text.

Comment 12 Francesco Romani 2017-11-20 12:34:35 UTC
patch merged -> MODIFIED

Comment 13 Raz Tamir 2017-11-24 18:11:25 UTC
Verified on ovirt-engine-ovirt-engine-4.2.0-0.5.master.el7.noarch:

# vdsm-client Host getVMFullList
...
         }
        }, 
        "clientIp": "", 
        "statusTime": "4572590680", 
        "vmName": "golden_env_mixed_virtio_1_0"
    }

Comment 14 Sandro Bonazzola 2017-12-20 10:51:26 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.