Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514923 - [mixed_version][stage upgrade] OSP11 -> OSP12 upgrade: unable to scale out compute nodes post upgrade on new bm node
Summary: [mixed_version][stage upgrade] OSP11 -> OSP12 upgrade: unable to scale out co...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-19 13:37 UTC by Raviv Bar-Tal
Modified: 2017-11-22 12:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-22 12:57:58 UTC


Attachments (Terms of Use)
sos report (deleted)
2017-11-19 13:37 UTC, Raviv Bar-Tal
no flags Details
deploy comman, files and logs (deleted)
2017-11-19 13:39 UTC, Raviv Bar-Tal
no flags Details
deploy info (deleted)
2017-11-19 13:40 UTC, Raviv Bar-Tal
no flags Details

Description Raviv Bar-Tal 2017-11-19 13:37:15 UTC
Created attachment 1355158 [details]
sos report

Description of problem:
After undercloud upgrade osp11 -> osp12 failed to deploy new compute node on new baremetal node.

Version-Release number of selected component (if applicable):
2017-11-17.1

How reproducible:


Steps to Reproduce:
1. Build 3controller and 2 compute nodes on your virt env.add them to baremetal nodes and introspect them.
2. Deploy overcloud with 3 controllers and 1 compute nodes.
3. Upgrade  your undercloud to osp12, (save osp11 tht dir "user/share/openstack-tripleo-heat-templates"
4. Try to scale out -run deploy command with 3 controllers and 2 computes (--template points to osp11 saved dir )

Actual results:
scale out failed

Expected results:
Additional compute node deployed 

Additional info:
This bug is different from bz1511874 as it tries to deploy compute on un-used node.

Comment 1 Raviv Bar-Tal 2017-11-19 13:39:56 UTC
Created attachment 1355159 [details]
deploy comman, files and logs

Comment 2 Raviv Bar-Tal 2017-11-19 13:40:39 UTC
Created attachment 1355160 [details]
deploy info

Comment 3 Marios Andreou 2017-11-20 09:39:11 UTC
o/ Raviv, firstpass of the untriaged list brings me here :)... why are we not using the openstack-tripleo-heat-templates-compat ... not sure if it is significant but noted you saved the 11 tht and used it. Did you do the minor update to the latest OSP11 before saving the undercloud tht?

Are we sure it isn't duplicate for  bz1511874 since I see the same    " u'message': u'No valid host was found. ', u'code': 500, u'" in the logs.

Comment 4 Raviv Bar-Tal 2017-11-20 13:52:46 UTC
Hi Marios \o.
To answer your questions:
1. yes, I do save osp11 tht and use them in the deploy command
   --templates /home/stack/openstack-tripleo-heat-templates_11
   About minor update - I use 'latest' build for installation, so update is not nessesary.

2. This is not the same as bz1511874 as I do have the resourse_class set to baremetal.

3. I did find this error in  nova-placement-api.log (which I didn't see before)

2017-11-20 04:46:21.334 24924 DEBUG nova.api.openstack.placement.wsgi_wrapper [req-d6fce732-c36a-4770-b894-78d61cea2613 d8e62c994c804ca0b4f269bcd98d8510 ae2575b765ab400cb0d387295f06c2a5 - default default] Placement API returning an error response: Unable to allocate inventory: Unable to create allocation for 'VCPU' on resource provider '814517e5-b255-48bf-8c42-5054ed23a9d6'. The requested amount would exceed the capacity. call_func /usr/lib/python2.7/site-packages/nova/api/openstack/placement/wsgi_wrapper.py:31

Comment 5 Marios Andreou 2017-11-20 16:06:35 UTC
as discussed on the upgrades call today reaching out to ironic team ( Adding TC of DFG:HardProv needinfo) to see if they have any ideas about this one given the current errors (comment #3   "No valid host was found." and comment #4 "Unable to create allocation for 'VCPU" )

Comment 6 Dmitry Tantsur 2017-11-20 16:21:43 UTC
Hi folks! Could you please show your flavor(s) after the upgrade?

Comment 7 Raviv Bar-Tal 2017-11-21 08:35:22 UTC
Hi Dmitry,
Below is the list of flavours after upgrade:

(undercloud) [stack@undercloud-0 ~]$ openstack flavor list
+--------------------------------------+---------------+-------+------+-----------+-------+-----------+
| ID                                   | Name          |   RAM | Disk | Ephemeral | VCPUs | Is Public |
+--------------------------------------+---------------+-------+------+-----------+-------+-----------+
| 111c5b3a-0aaf-43f7-95b5-ddc2dcaa2a15 | swift-storage |  4096 |   40 |         0 |     1 | True      |
| 2688374a-8af8-46af-b849-fa38f7fd402d | ceph-storage  |  4096 |   40 |         0 |     1 | True      |
| 39bc9f59-2aa3-4b8d-ae0f-801461431d57 | control       |  4096 |   40 |         0 |     1 | True      |
| 8a9e3452-de8a-421c-bb3a-b694f20f9615 | compute       |  6144 |   47 |         0 |     3 | True      |
| acfde51e-fba9-4c9c-88a8-e59b9e172a00 | controller    | 32768 |   37 |         0 |     7 | True      |
| c0ac37d5-0c40-410b-b9c0-ab5271a2f55b | baremetal     |  4096 |   16 |         0 |     1 | True      |
| eeb86df7-0e20-422d-bbfa-7c93990b6b36 | block-storage |  4096 |   40 |         0 |     1 | True      |
+--------------------------------------+---------------+-------+------+-----------+-------+-----------+
(undercloud) [stack@undercloud-0 ~]$

Comment 8 Raviv Bar-Tal 2017-11-22 12:57:58 UTC
This bug was fixed unintentionally in lates build - 2017-11-21.5


Note You need to log in before you can comment on or make changes to this bug.