Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514897 - 'KILL' and 'LeavePaused' values could not be set for 'Resume Behaviour' of HA with no lease VMS
Summary: 'KILL' and 'LeavePaused' values could not be set for 'Resume Behaviour' of HA...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Tomas Jelinek
QA Contact: Polina
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-19 10:13 UTC by Polina
Modified: 2018-01-25 04:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, if a virtual machine was paused due to a storage error, it would be resumed again when the storage domain came back up. This was not always desirable (for example, high availability can complicate the situation). Now, there are three resume behaviors which can be configured per virtual machine: - KILL: will kill the virtual machine if it was paused for longer than 80 seconds - LEAVE_PAUSED: leaves the virtual machine paused - RESUME: resumes the virtual machine
Clone Of:
Environment:
Last Closed: 2017-12-20 11:05:59 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+
rule-engine: planning_ack+
tjelinek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84629 master MERGED webadmin: make sure to setup the resume behavior after build 2017-11-24 14:11:07 UTC

Description Polina 2017-11-19 10:13:12 UTC
Description of problem:
For HA VMs with no lease the only option could be set is AUTORESUME. When trying to choose KILL/LeavePaused for a HA VM with no lease, it is always reset to AUTO RESUME.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Open Edit tab for a VM which is in Down state. Choose High Available tab.
2. Check High Available, No lease, KILL option for Resume Behaviour, OK
3. Open Edit tab again  - you see that the chosen option for RESUME Behaviour is reset to AUTORESUME. The same happens upon 'Leave Paused' choise

Actual results:
The Resume Behavior for HA, no lease VMs always reset to AUTORESUME

Expected results:
The checked option (KILL or Leave Paused) must be saved as chosen.

Additional info:

Comment 1 Polina 2017-12-11 07:41:41 UTC
verified in build rhvm-4.2.0-0.6.el7.noarch

Comment 2 Sandro Bonazzola 2017-12-20 11:05:59 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.