Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514840 - Overcloud Update to OSP10z6 fails on Step4 in all compute nodes.
Summary: Overcloud Update to OSP10z6 fails on Step4 in all compute nodes.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 10.0 (Newton)
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-18 20:54 UTC by Siggy Sigwald
Modified: 2018-02-23 18:44 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-23 17:30:36 UTC


Attachments (Terms of Use)

Description Siggy Sigwald 2017-11-18 20:54:55 UTC
Description of problem:
Step 4 fails (all compute nodes) with
Error: Could not set 'file' on ensure: No such file or directory - /etc/nova/migration/authorized_keys20171117-202194-zyg2kc.lock at 187:/etc/puppet/modules/tripleo/manifests/profile/base/nova.pp
when updating Overcloud that is in production. I tested Overcloud deploy with new RHOSP image released in z6 and I don't see this error, so looking deep into this issue I see that directory /etc/nova/migration/ is already create in the new overcloud image released with z6 but old Images used in production today does not have that directory, and that is the reason overcloud update fails, see below in a site that was not updated to z6

[root@ ~]# cd /etc/nova/
[root@ nova]# ll
total 308
-rw-r-----. 1 root nova   2717 Dec 19  2016 api-paste.ini
-rw-r-----. 1 root nova   3562 Nov 14 23:13 nova.conf
-rw-r-----. 1 root nova 289245 Feb  7  2017 nova.conf.rpmnew
-rw-r-----. 1 root nova      4 Nov 14 23:13 policy.json
-rw-r-----. 1 root root      4 Nov 14 23:13 policy.json.bk
-rw-r--r--. 1 root root     71 Feb  7  2017 release
-rw-r-----. 1 root nova    966 Dec 19  2016 rootwrap.conf
[root@ nova]#

so /etc/puppet/modules/tripleo/manifests/profile/base/nova.pp is trying to create keys files without checking if directory is there or not

      file { '/etc/nova/migration/authorized_keys':
        content => $migration_authorized_keys,
        mode    => '0640',
        owner   => 'root',
        group   => 'nova_migration',
        require => Package['openstack-nova-migration']
      }

      file { '/etc/nova/migration/identity':
        content => $migration_identity,
        mode    => '0600',
        owner   => 'nova',
        group   => 'nova',
        require => Package['openstack-nova-migration']
      }

Version-Release number of selected component (if applicable):


How reproducible:
every time

Comment 1 Ollie Walsh 2017-11-23 18:54:20 UTC

*** This bug has been marked as a duplicate of bug 1466882 ***

Comment 2 Ollie Walsh 2017-11-24 15:01:24 UTC

*** This bug has been marked as a duplicate of bug 1517302 ***


Note You need to log in before you can comment on or make changes to this bug.