Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514813 - SELinux is preventing snapd from 'getattr' accesses on the lnk_file /etc/pki/tls/certs/ca-bundle.crt.
Summary: SELinux is preventing snapd from 'getattr' accesses on the lnk_file /etc/pki/...
Keywords:
Status: CLOSED DUPLICATE of bug 1514800
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2c75e4ab26c151f7580402ef905...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-18 17:30 UTC by Predrag
Modified: 2018-04-09 11:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-20 12:36:43 UTC


Attachments (Terms of Use)

Description Predrag 2017-11-18 17:30:20 UTC
Description of problem:
SELinux is preventing snapd from 'getattr' accesses on the lnk_file /etc/pki/tls/certs/ca-bundle.crt.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that snapd should be allowed getattr access on the ca-bundle.crt lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'snapd' --raw | audit2allow -M my-snapd
# semodule -X 300 -i my-snapd.pp

Additional Information:
Source Context                system_u:system_r:snappy_t:s0
Target Context                system_u:object_r:cert_t:s0
Target Objects                /etc/pki/tls/certs/ca-bundle.crt [ lnk_file ]
Source                        snapd
Source Path                   snapd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.13.12-300.fc27.x86_64 #1 SMP Wed
                              Nov 8 16:38:01 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-11-16 21:51:44 CET
Last Seen                     2017-11-16 21:51:44 CET
Local ID                      ff1f53dd-fe31-4358-afda-0e33c6310bd1

Raw Audit Messages
type=AVC msg=audit(1510865504.778:3469): avc:  denied  { getattr } for  pid=5001 comm="snapd" path="/etc/pki/tls/certs/ca-bundle.crt" dev="dm-1" ino=1967648 scontext=system_u:system_r:snappy_t:s0 tcontext=system_u:object_r:cert_t:s0 tclass=lnk_file permissive=1


Hash: snapd,snappy_t,cert_t,lnk_file,getattr


Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.13.12-300.fc27.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2017-11-20 12:36:43 UTC

*** This bug has been marked as a duplicate of bug 1514800 ***

Comment 2 Victor Ferreira Franco 2018-03-25 19:45:35 UTC
*** Bug 1560303 has been marked as a duplicate of this bug. ***

Comment 3 aekryz 2018-04-09 11:11:50 UTC
*** Bug 1565086 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.