Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514807 - SELinux is preventing snapd from using the 'dac_read_search' capabilities.
Summary: SELinux is preventing snapd from using the 'dac_read_search' capabilities.
Keywords:
Status: CLOSED DUPLICATE of bug 1514800
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:532611cbc711dadf1c3f5d6265a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-18 17:26 UTC by Predrag
Modified: 2017-11-20 12:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-20 12:35:55 UTC


Attachments (Terms of Use)

Description Predrag 2017-11-18 17:26:08 UTC
Description of problem:
SELinux is preventing snapd from using the 'dac_read_search' capabilities.

*****  Plugin dac_override (91.4 confidence) suggests   **********************

If you want to help identify if domain needs this access or you have a file with the wrong permissions on your system
Then turn on full auditing to get path information about the offending file and generate the error again.
Do

Turn on full auditing
# auditctl -w /etc/shadow -p w
Try to recreate AVC. Then execute
# ausearch -m avc -ts recent
If you see PATH record check ownership/permissions on file, and fix it,
otherwise report as a bugzilla.

*****  Plugin catchall (9.59 confidence) suggests   **************************

If you believe that snapd should have the dac_read_search capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'snapd' --raw | audit2allow -M my-snapd
# semodule -X 300 -i my-snapd.pp

Additional Information:
Source Context                system_u:system_r:snappy_t:s0
Target Context                system_u:system_r:snappy_t:s0
Target Objects                Unknown [ capability ]
Source                        snapd
Source Path                   snapd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.13.12-300.fc27.x86_64 #1 SMP Wed
                              Nov 8 16:38:01 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-11-16 21:51:29 CET
Last Seen                     2017-11-16 21:51:29 CET
Local ID                      fd428b57-ad89-44b1-84a4-fb5e967462da

Raw Audit Messages
type=AVC msg=audit(1510865489.671:3192): avc:  denied  { dac_read_search } for  pid=2316 comm="snapd" capability=2  scontext=system_u:system_r:snappy_t:s0 tcontext=system_u:system_r:snappy_t:s0 tclass=capability permissive=1


Hash: snapd,snappy_t,snappy_t,capability,dac_read_search


Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.13.12-300.fc27.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2017-11-20 12:35:55 UTC

*** This bug has been marked as a duplicate of bug 1514800 ***


Note You need to log in before you can comment on or make changes to this bug.