Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514798 - SELinux is preventing gdk-pixbuf-thum from using the 'dac_override' capabilities.
Summary: SELinux is preventing gdk-pixbuf-thum from using the 'dac_override' capabilit...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d3332197c31e73111af3d3d97ba...
: 1470024 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-18 17:21 UTC by Predrag
Modified: 2018-07-29 06:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-20 13:49:03 UTC


Attachments (Terms of Use)

Description Predrag 2017-11-18 17:21:15 UTC
Description of problem:
SELinux is preventing gdk-pixbuf-thum from using the 'dac_override' capabilities.

*****  Plugin dac_override (91.4 confidence) suggests   **********************

If you want to help identify if domain needs this access or you have a file with the wrong permissions on your system
Then turn on full auditing to get path information about the offending file and generate the error again.
Do

Turn on full auditing
# auditctl -w /etc/shadow -p w
Try to recreate AVC. Then execute
# ausearch -m avc -ts recent
If you see PATH record check ownership/permissions on file, and fix it,
otherwise report as a bugzilla.

*****  Plugin catchall (9.59 confidence) suggests   **************************

If you believe that gdk-pixbuf-thum should have the dac_override capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gdk-pixbuf-thum' --raw | audit2allow -M my-gdkpixbufthum
# semodule -X 300 -i my-gdkpixbufthum.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Objects                Unknown [ capability ]
Source                        gdk-pixbuf-thum
Source Path                   gdk-pixbuf-thum
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.8-300.fc26.x86_64 #1 SMP Thu
                              Jun 29 20:09:48 UTC 2017 x86_64 x86_64
Alert Count                   38
First Seen                    2017-07-12 11:02:23 CEST
Last Seen                     2017-07-12 11:02:25 CEST
Local ID                      04ec1205-f5ae-414f-936d-5787d1007001

Raw Audit Messages
type=AVC msg=audit(1499850145.744:376): avc:  denied  { dac_override } for  pid=15686 comm="totem-video-thu" capability=1  scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tclass=capability permissive=0


Hash: gdk-pixbuf-thum,thumb_t,thumb_t,capability,dac_override


Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.13.12-300.fc27.x86_64
type:           libreport

Potential duplicate: bug 1470024

Comment 1 Lukas Vrabec 2017-11-20 13:47:53 UTC
*** Bug 1470024 has been marked as a duplicate of this bug. ***

Comment 2 Lukas Vrabec 2017-11-20 13:49:03 UTC
This looks like issue in file permissions on your system. Please see following blog to fix this issue: 

http://danwalsh.livejournal.com/69478.html

Thanks,
Lukas.

Comment 3 Roberto Gonzalez 2018-07-29 06:58:40 UTC
Description of problem:
despues de una actualizacion

Version-Release number of selected component:
selinux-policy-3.13.1-283.35.fc27.noarch

Additional info:
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.16.11-200.fc27.x86_64
type:           libreport


Note You need to log in before you can comment on or make changes to this bug.