Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514781 - AttributeError: 'str' object has no attribute 'name'
Summary: AttributeError: 'str' object has no attribute 'name'
Keywords:
Status: CLOSED DUPLICATE of bug 1502587
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Blivet Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1879fa2d43fcf82f9c3ebe55a7b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-18 14:04 UTC by lucas.veltkamp
Modified: 2017-11-20 09:26 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-20 09:26:44 UTC


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2017-11-18 14:04 UTC, lucas.veltkamp
no flags Details
File: anaconda.log (deleted)
2017-11-18 14:04 UTC, lucas.veltkamp
no flags Details
File: environ (deleted)
2017-11-18 14:04 UTC, lucas.veltkamp
no flags Details
File: journalctl (deleted)
2017-11-18 14:04 UTC, lucas.veltkamp
no flags Details
File: lsblk_output (deleted)
2017-11-18 14:04 UTC, lucas.veltkamp
no flags Details
File: nmcli_dev_list (deleted)
2017-11-18 14:04 UTC, lucas.veltkamp
no flags Details
File: os_info (deleted)
2017-11-18 14:04 UTC, lucas.veltkamp
no flags Details
File: program.log (deleted)
2017-11-18 14:04 UTC, lucas.veltkamp
no flags Details
File: storage.log (deleted)
2017-11-18 14:04 UTC, lucas.veltkamp
no flags Details
File: ifcfg.log (deleted)
2017-11-18 14:04 UTC, lucas.veltkamp
no flags Details

Description lucas.veltkamp 2017-11-18 14:04:11 UTC
Version-Release number of selected component:
anaconda-core-27.20.4-4.fc27.x86_64

The following was filed automatically by anaconda:
anaconda 27.20.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.6/site-packages/blivet/tasks/fsminsize.py", line 131, in do_task
    raise FSError("failed to get block size for %s filesystem on %s" % (self.fs.mount_type, self.fs.device.name))
  File "/usr/lib/python3.6/site-packages/blivet/formats/fs.py", line 340, in update_size_info
    result = self._minsize.do_task()
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/formats/fs.py", line 132, in __init__
    self.update_size_info()
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/formats/__init__.py", line 98, in get_format
    fmt = fmt_class(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/populator/helpers/formatpopulator.py", line 89, in run
    self.device.format = formats.get_format(type_spec, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/populator/populator.py", line 345, in handle_format
    helper_class(self, info, device).run()
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/populator/populator.py", line 318, in handle_device
    self.handle_format(info, device)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/populator/populator.py", line 519, in _populate
    self.handle_device(dev)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/populator/populator.py", line 454, in populate
    self._populate()
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 272, in reset
    self.devicetree.populate(cleanup_only=cleanup_only)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/osinstall.py", line 1175, in storage_initialize
    storage.reset()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 252, in run
    threading.Thread.run(self)
AttributeError: 'str' object has no attribute 'name'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz root=live:CDLABEL=Fedora-WS-Live-27-1-6 rd.live.image quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.13.9-300.fc27.x86_64
other involved packages: python3-libs-3.6.2-13.fc27.x86_64, python3-blivet-2.1.11-3.fc27.noarch
product:        Fedora
release:        Fedora release 27 (Twenty Seven)
type:           anaconda
version:        27

Comment 1 lucas.veltkamp 2017-11-18 14:04:22 UTC
Created attachment 1354724 [details]
File: anaconda-tb

Comment 2 lucas.veltkamp 2017-11-18 14:04:25 UTC
Created attachment 1354725 [details]
File: anaconda.log

Comment 3 lucas.veltkamp 2017-11-18 14:04:28 UTC
Created attachment 1354726 [details]
File: environ

Comment 4 lucas.veltkamp 2017-11-18 14:04:32 UTC
Created attachment 1354727 [details]
File: journalctl

Comment 5 lucas.veltkamp 2017-11-18 14:04:34 UTC
Created attachment 1354728 [details]
File: lsblk_output

Comment 6 lucas.veltkamp 2017-11-18 14:04:37 UTC
Created attachment 1354729 [details]
File: nmcli_dev_list

Comment 7 lucas.veltkamp 2017-11-18 14:04:39 UTC
Created attachment 1354730 [details]
File: os_info

Comment 8 lucas.veltkamp 2017-11-18 14:04:41 UTC
Created attachment 1354731 [details]
File: program.log

Comment 9 lucas.veltkamp 2017-11-18 14:04:44 UTC
Created attachment 1354732 [details]
File: storage.log

Comment 10 lucas.veltkamp 2017-11-18 14:04:46 UTC
Created attachment 1354733 [details]
File: ifcfg.log

Comment 11 Jiri Konecny 2017-11-20 09:17:53 UTC
This looks like an issue in our storage library.

Changing components.

Comment 12 Vratislav Podzimek 2017-11-20 09:26:44 UTC

*** This bug has been marked as a duplicate of bug 1502587 ***


Note You need to log in before you can comment on or make changes to this bug.