Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514723 - Access Control: No option to 'Delete selected Groups' when selecting multiple groups under Access Control EVM Groups
Summary: Access Control: No option to 'Delete selected Groups' when selecting multiple...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.10.0
Assignee: Hilda Stastna
QA Contact: Antonin Pagac
URL:
Whiteboard: webui:rbac
: 1473828 (view as bug list)
Depends On:
Blocks: 1520671 1523777
TreeView+ depends on / blocked
 
Reported: 2017-11-18 02:32 UTC by Landon LaSmith
Modified: 2018-06-21 21:22 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1520671 1523777 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:22:29 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1473828 None None None Never

Internal Links: 1473828

Description Landon LaSmith 2017-11-18 02:32:01 UTC
Description of problem: On the Access Control EVM Groups checklist page, you can select multiple groups in the checklist but there is no visible option to 'Delete selected selected Groups'.  This feature is available for Users/Roles and it was present in 5.7. 

Version-Release number of selected component (if applicable): 5.9.0.9


How reproducible: 100%


Steps to Reproduce:
1. Login to CFME appliance webui as admin
2. Navigate to Configuration and select Access Control in the accordion
3. Under Access Control, select the root Group element
4. Check one more groups in the checklist
5. In the Configuration pulldown, confirm there is no visible delete option

Actual results: There is no visible option to delete when selecting one or more groups on the Access Control EVM Groups page checklist


Expected results: Can delete one or groups when selected on Access Control EVM Groups page checklist


Additional info: Delete is available when viewing the details of individual groups

Comment 3 Hilda Stastna 2017-12-04 15:42:10 UTC
*** Bug 1473828 has been marked as a duplicate of this bug. ***

Comment 4 Hilda Stastna 2017-12-04 16:10:59 UTC
fixing https://github.com/ManageIQ/manageiq-ui-classic/pull/2922


Note You need to log in before you can comment on or make changes to this bug.