Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514633 - Failed to synchronize cache for repo »updates«
Summary: Failed to synchronize cache for repo »updates«
Keywords:
Status: CLOSED DUPLICATE of bug 1492036
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: 27
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-18 00:33 UTC by H.-P. Sorge
Modified: 2017-11-30 09:55 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-30 09:55:00 UTC


Attachments (Terms of Use)

Description H.-P. Sorge 2017-11-18 00:33:19 UTC
Description of problem:

1. <dnf system-upgrade reboot> fails to upgrade.
2. entry in /var/log/messages: Failed to synchronize cache for repo »updates« 
3. from /etc/yum.repos.d/fedora-updates.repo
    mirrors.fedoraproject.org did not get resolved. 
    t-online returned: 
    Die von Ihnen eingegebene Internetadresse ... konnte nicht gefunden werden.

4. next day repeat:
   dnf --refresh upgrade
   dnf system-upgrade download --releasever=27
   dnf system-upgrade reboot
   mirrors.fedoraproject.org did get resolved!
   Same fail result.

5. <dnf clean all> has no effect.
   Downloaded rpm will be kept and not downloaded again.

6. next day some more repeats:
   dnf --refresh upgrade
   dnf system-upgrade download --releasever=27
   dnf system-upgrade reboot
   (nb mirrors.fedoraproject.org did get resolved!)
   Same fail result.

7. Observation: /var/lib/dnf/system-upgrade contains several subdirectories 
   like updates-xxxxxxxxxxxxxxxxx.

8. rm -rf /var/lib/dnf/system-upgrade/*
   dnf --refresh upgrade
   dnf system-upgrade download --releasever=27 # download all rpm again
   dnf system-upgrade reboot
   SUCCESS 

Version-Release number of selected component (if applicable): 


How reproducible:  not attempted 


Steps to Reproduce:
1.  ./.
2.  ./. 
3.  ./.

Actual results:
./.

Expected results:
<dnf clean all> should clean locally stored rpm   

Additional info:
It looks like the multiple entries like 
/var/lib/dnf/system-upgrade/updates-xxxxxxxxxxxxxxxxx
do not get handled correctly .. (after a failing name resolution??)

Comment 1 Michael S. 2017-11-24 19:31:07 UTC
I think this problem is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1514754 , could you take a look at my comment and see if this fix the issue for you ? (the part about check_config_file_age = false)

Comment 2 Christophe Fergeau 2017-11-27 09:00:34 UTC
Fwiw, had the same issue (started the upgrade process last week, download failed a few times because of local issues, finally was able to try and move forward today). On system-upgrade reboot, I was getting this error about the Updates repository not being accessible. Removing the system-upgrade cache and trying again allowed the upgrade to complete.

Comment 3 Marek Blaha 2017-11-30 09:55:00 UTC

*** This bug has been marked as a duplicate of bug 1492036 ***


Note You need to log in before you can comment on or make changes to this bug.