Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514593 - [Regression] Not able to Submit service catalog , Save button is not enabled.
Summary: [Regression] Not able to Submit service catalog , Save button is not enabled.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Harpreet Kataria
QA Contact: Dave Johnson
URL:
Whiteboard: service, testathon
: 1515322 1515496 1515841 (view as bug list)
Depends On:
Blocks: 1517882
TreeView+ depends on / blocked
 
Reported: 2017-11-17 20:22 UTC by Shveta
Modified: 2018-06-21 20:34 UTC (History)
11 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1517882 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:34:05 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)
button disabled (deleted)
2017-11-17 20:22 UTC, Shveta
no flags Details
screenshot (deleted)
2017-11-20 17:18 UTC, Loic Avenel
no flags Details

Description Shveta 2017-11-17 20:22:34 UTC
Created attachment 1354317 [details]
button disabled

Description of problem:


Version-Release number of selected component (if applicable):
5.9.0.9.20171115202245_7429f75 

How reproducible:


Steps to Reproduce:
1. Create a dialog.
2. Create catalog and then catalog item using the above created dialog.
3. Order Service catalog, Save or submit button is always disabled.

Actual results:


Expected results:


Additional info:

Comment 3 Shveta 2017-11-17 20:36:55 UTC
Please check https://10.8.197.112 .
Order catalog item once , button is disabled .
Try to order again , Submit button does not even show up.

Comment 4 Harpreet Kataria 2017-11-20 15:59:32 UTC
*** Bug 1515322 has been marked as a duplicate of this bug. ***

Comment 5 Loic Avenel 2017-11-20 17:18:02 UTC
Created attachment 1355965 [details]
screenshot

Comment 9 CFME Bot 2017-11-21 10:18:23 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/2572be7fa8cb61b29bc7628a3a921d5349ce3fd2

commit 2572be7fa8cb61b29bc7628a3a921d5349ce3fd2
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Nov 20 15:42:04 2017 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Nov 20 17:36:25 2017 -0500

    Fixed visibility of form buttons, paging div etc in Catalog Explorer
    
    - When ordering a Service Catalog, form buttons were displayed along with paging div randomly and when ordering a service from list view it was displaying double form buttons. Fixed several issues with form buttons visibility.
    - Fixed an error when pressing "cancel" on Service catalog order screen, this was only happening when pressing going to order screen from Service Catalog details screen.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1514593

 app/controllers/application_controller/dialog_runner.rb | 1 +
 app/controllers/catalog_controller.rb                   | 7 ++++---
 2 files changed, 5 insertions(+), 3 deletions(-)

Comment 10 Harpreet Kataria 2017-11-21 14:49:09 UTC
*** Bug 1515496 has been marked as a duplicate of this bug. ***

Comment 11 Harpreet Kataria 2017-11-21 14:52:37 UTC
*** Bug 1515841 has been marked as a duplicate of this bug. ***

Comment 14 CFME Bot 2017-11-21 22:48:27 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/c877220d79c99584ef749ff6c50b3bc6187bb4ab

commit c877220d79c99584ef749ff6c50b3bc6187bb4ab
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Nov 21 15:56:01 2017 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Nov 21 16:46:44 2017 -0500

    Fixed if condition to check for action instead of action_name
    
    When Order button is clicked from list view, action_name value is sent up as x_button making the code go thru if condition and show double buttons on screen.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1514593

 app/controllers/catalog_controller.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 15 CFME Bot 2017-11-22 21:18:27 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/74bcedc9b412ea1a2c1ac517c1a625e230baa832

commit 74bcedc9b412ea1a2c1ac517c1a625e230baa832
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Nov 21 18:00:51 2017 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Nov 21 18:00:51 2017 -0500

    Spec test to verify a fix in PR 2790
    
    Spec test to verify fix in https://github.com/ManageIQ/manageiq-ui-classic/pull/2790
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1514593

 app/controllers/catalog_controller.rb       |  4 ++--
 spec/controllers/catalog_controller_spec.rb | 29 +++++++++++++++++++++++++++++
 2 files changed, 31 insertions(+), 2 deletions(-)


Note You need to log in before you can comment on or make changes to this bug.