Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514575 - Node agent unable to collect network details
Summary: Node agent unable to collect network details
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-node-agent
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: gowtham
QA Contact: Bala Konda Reddy M
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 19:25 UTC by Nishanth Thomas
Modified: 2017-12-18 04:37 UTC (History)
7 users (show)

Fixed In Version: tendrl-node-agent-1.5.4-3.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:37:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Github Tendrl node-agent issues 674 None None None 2017-11-17 19:25:32 UTC

Description Nishanth Thomas 2017-11-17 19:25:32 UTC
Description of problem:

Node-agent unable collect network details because of error 'ethtool: bad command line argument(s)\nFor more information run ethtool -h\nsh: vdsmdummy: command not found'. While executing hwinfo command node-agent is skipping network info because of above error. The problem is output variable contains all information about network but err variable have this error. So node-agent is not processing further. So skip this error for now to collect the network details.

Comment 3 Martin Kudlej 2017-11-28 17:03:43 UTC
Could you please describe reproducer for this bug?

Comment 4 Rohan Kanade 2017-12-07 09:08:36 UTC
@MartinK,

To reproduce this issue, you need to use Ovirt/RHEVM and create VM's (storage nodes and Tendrl server). Install tendrl-node-agent on any such VM and check logs, although you wont see the issue with latest Tendrl builds.


The issue specifically is about  "vdsdummy"  which is a bridge that VDSM daemon creates. When such bridge is seen, the hwinfo/ethtool used by tendrl-node-agent returns a warning/traceback along with list of networks. We have simply sent a patch which ignores such warnings and process the networks as is.


https://access.redhat.com/solutions/962933

https://github.com/Tendrl/node-agent/blob/master/tendrl/node_agent/node_sync/network_sync.py#L104

Comment 11 errata-xmlrpc 2017-12-18 04:37:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.