Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 151451 - Text mode clobbered when switching from X to virtual console
Summary: Text mode clobbered when switching from X to virtual console
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-03-18 02:32 UTC by Robin Green
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 09:45:53 UTC


Attachments (Terms of Use)
Xorg.0.log (deleted)
2005-03-18 02:38 UTC, Robin Green
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 2995 None None None Never

Description Robin Green 2005-03-18 02:32:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
Similar to bug 151252, but I get different colours each time.

After starting X, VGA text mode virtual consoles have pallette(?) problems. Foreground colour, background colour, border colour and whether it flashes, and horizontal offsets, are fairly random. Also, sometimes my monitor does not recognise the mode.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start X
2. Press CTRL+ALT+F1
 

Actual Results:  Foreground colour, background colour, border colour and whether it flashes, are all fairly random.

Expected Results:  White text on black background.

Additional info:

The version number of the Xorg driver in use (savage) has not changed since FC3. So I presume this is due to a change in the Xorg code rather than a driver-specific bug.

X itself - although probably the cause of this bug - is unaffected by this bug.

Comment 1 Robin Green 2005-03-18 02:38:27 UTC
Created attachment 112116 [details]
Xorg.0.log

Comment 2 Mike A. Harris 2005-04-11 10:15:10 UTC
The driver version number remaining the same is not an indication of an
identical driver unfortunately.  Driver changes are made all the time to
Xorg drivers without the driver version being updated.  While that is
unfortunate from a support standpoing, it happens.

Please report this problem via the X.org bugzilla located at:

    http://bugs.freedesktop.org - in the "xorg" component

Once you have filed your bug report in X.org bugzilla, please paste the
URL here and we will track this issue in the X.Org bugzilla, and review
any fixes that become available for consideration in future Fedora Core
updates.


Comment 3 Mike A. Harris 2005-04-11 10:16:13 UTC
Setting status to "NEEDINFO", awaiting upstream bug URL for tracking.

Comment 4 Robin Green 2005-04-12 16:14:09 UTC
Upstream bug filed at https://bugs.freedesktop.org/show_bug.cgi?id=2995

Comment 5 Mike A. Harris 2005-04-15 09:45:53 UTC
Thanks, setting status to "UPSTREAM", and tracking in upstream bugzilla.


Note You need to log in before you can comment on or make changes to this bug.