Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514503 - Duplicate field called Type in Expression Field
Summary: Duplicate field called Type in Expression Field
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.10.0
Assignee: Yuri Rudman
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 1530685 1531178
TreeView+ depends on / blocked
 
Reported: 2017-11-17 15:30 UTC by mkanoor
Modified: 2018-06-21 20:25 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1530685 1531178 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:25:58 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Duplicate Types (deleted)
2017-11-17 15:30 UTC, mkanoor
no flags Details

Description mkanoor 2017-11-17 15:30:31 UTC
Created attachment 1354211 [details]
Duplicate Types

Description of problem:
When creating an MiqExpression on the ExtManagementSystem object we see 2 fields with the same name called 'Provider: Type'.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create an Expression builder on the ExtManagementSystem or Expression Method in Automate.
2. Click on the drop down for the field and see Provider: Type twice
3.

Actual results:
See duplicates

Expected results:
Should have different names so a user would know what the different types are

Additional info:

The first type creates an expression that looks like
{"="=>{"field"=>"ExtManagementSystem-emstype_description", "value"=>"ManageIQ::Providers::Amazon::CloudManager"}, :token=>1}

The second expression looks like 
{"STARTS WITH"=>{"field"=>"ExtManagementSystem-type", "value"=>"ManageIQ::Providers::Amazon::CloudManager"}, :token=>1}

The conflicting fields are
* ExtManagementSystem-emstype_description 
* ExtManagementSystem-type

Comment 4 CFME Bot 2017-12-21 20:36:52 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/75d828d565b2ef43f0bc3b18dd0f37d0c5fd1e5d

commit 75d828d565b2ef43f0bc3b18dd0f37d0c5fd1e5d
Author:     Yuri Rudman <yrudman@redhat.com>
AuthorDate: Fri Dec 15 15:17:12 2017 -0500
Commit:     Yuri Rudman <yrudman@redhat.com>
CommitDate: Fri Dec 15 15:17:12 2017 -0500

    resolved ambiguous Provider:Type field when build MiqExpression
    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1514503

 locale/en.yml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


Note You need to log in before you can comment on or make changes to this bug.