Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514446 - packaging problem prevents upgrade
Summary: packaging problem prevents upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 1513286
Alias: None
Product: Fedora
Classification: Fedora
Component: compiler-rt
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 12:45 UTC by Przemek Klosowski
Modified: 2018-01-19 16:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-19 16:28:41 UTC


Attachments (Terms of Use)

Description Przemek Klosowski 2017-11-17 12:45:27 UTC
Description of problem:
On a F27 freshly upgraded from F26, dnf upgrade is blocked by a multiple-architecture related conflict. I don't remember why I have both i686 and x86_64 installed--it was almost certainly automatically done by dnf.


Version-Release number of selected component (if applicable):
compiler-rt-4.0.1-4.fc27.i686

How reproducible: every time


Steps to Reproduce:
1. dnf -y upgrade

Actual results:

 Problem: compiler-rt-4.0.1-4.fc27.i686 has inferior architecture
  - cannot install both compiler-rt-4.0.1-5.fc27.x86_64 and compiler-rt-4.0.1-4.fc27.x86_64
  - cannot install both compiler-rt-4.0.1-4.fc27.x86_64 and compiler-rt-4.0.1-5.fc27.x86_64
  - cannot install the best update candidate for package compiler-rt-4.0.1-4.fc27.i686
  - cannot install the best update candidate for package compiler-rt-4.0.1-4.fc27.x86_64
================================================================================
 Package             Arch           Version               Repository       Size
================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 compiler-rt         x86_64         4.0.1-5.fc27          updates         1.7 M



Expected results: no conflicts, sucessful upgrade

Comment 1 Przemek Klosowski 2017-11-17 12:48:22 UTC
As a workaround, 

dnf -y update --best --allowerasing

resolves the problem by removing i686 versions

clang-libs                   i686                 4.0.1-5.fc27                  @fedora                 45 M
 compiler-rt                  i686                 4.0.1-4.fc27                  @fedora                 15 M
 mesa-libOpenCL               i686                 17.2.4-2.fc27                 @updates               1.9 M

I think it's OK because I still have the .x86_64 versions which is what I care about.

Comment 2 Tom Stellard 2018-01-19 16:28:41 UTC

*** This bug has been marked as a duplicate of bug 1513286 ***


Note You need to log in before you can comment on or make changes to this bug.