Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514419 - gluster volume splitbrain info needs to display output of each brick in a stream fashion instead of buffering and dumping at the end
Summary: gluster volume splitbrain info needs to display output of each brick in a str...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.13
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Karthik U S
QA Contact:
URL:
Whiteboard:
Depends On: 1506104
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 11:13 UTC by Karthik U S
Modified: 2017-12-08 17:46 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.13.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1506104
Environment:
Last Closed: 2017-12-08 17:46:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-11-17 11:16:56 UTC
REVIEW: https://review.gluster.org/18797 (cluster/afr: Print heal info split-brain output in stream fashion) posted (#1) for review on release-3.13 by Karthik U S

Comment 2 Worker Ant 2017-11-22 12:50:19 UTC
REVIEW: https://review.gluster.org/18842 (cluster/afr: Print heal info summary output in stream fashion) posted (#1) for review on release-3.13 by Karthik U S

Comment 3 Worker Ant 2017-11-27 18:13:32 UTC
COMMIT: https://review.gluster.org/18842 committed in release-3.13 by \"Karthik U S\" <ksubrahm@redhat.com> with a commit message- cluster/afr: Print heal info summary output in stream fashion

Problem:
The heal info summary was printing the output at the end after
crawling for pending heal entries completes on all the bricks.

Fix:
Printing the output immediately after the crawl on individual brick
completes, so that it won't give the impression of CLI being hung.

Change-Id: Ieaf5718736a7ee6837bac02bd30a95836e605dab
BUG: 1514419
Signed-off-by: karthik-us <ksubrahm@redhat.com>
(cherry picked from commit 77e3bc671aab2fda68ada53f38ec368b20675f59)

Comment 4 Shyamsundar 2017-12-08 17:46:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.