Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514405 - SELinux is preventing openvpn from 'read' accesses on the file 4155204D656C626F75726E652E6F76706E.
Summary: SELinux is preventing openvpn from 'read' accesses on the file 4155204D656C62...
Keywords:
Status: CLOSED DUPLICATE of bug 1514402
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d48b1a22e98c8ea1abbcb7cada5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 10:32 UTC by Jas
Modified: 2017-11-20 13:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-20 13:52:19 UTC


Attachments (Terms of Use)

Description Jas 2017-11-17 10:32:04 UTC
Description of problem:
SELinux is preventing openvpn from 'read' accesses on the file 4155204D656C626F75726E652E6F76706E.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that openvpn should be allowed read access on the 4155204D656C626F75726E652E6F76706E file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'openvpn' --raw | audit2allow -M my-openvpn
# semodule -X 300 -i my-openvpn.pp

Additional Information:
Source Context                system_u:system_r:openvpn_t:s0
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                4155204D656C626F75726E652E6F76706E [ file ]
Source                        openvpn
Source Path                   openvpn
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-260.13.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.13.11-200.fc26.x86_64 #1 SMP Thu
                              Nov 2 18:28:35 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-11-17 21:17:04 AEDT
Last Seen                     2017-11-17 21:17:04 AEDT
Local ID                      50a71f02-d880-4b75-b3fd-cb8ad344a323

Raw Audit Messages
type=AVC msg=audit(1510913824.85:102): avc:  denied  { read } for  pid=694 comm="openvpn" name=4155204D656C626F75726E652E6F76706E dev="sda5" ino=793465 scontext=system_u:system_r:openvpn_t:s0 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file permissive=1


Hash: openvpn,openvpn_t,admin_home_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-260.13.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.13.11-200.fc26.x86_64
type:           libreport

Potential duplicate: bug 1183075

Comment 1 Lukas Vrabec 2017-11-20 13:52:19 UTC

*** This bug has been marked as a duplicate of bug 1514402 ***


Note You need to log in before you can comment on or make changes to this bug.